Jump to content

digman

Members
  • Content Count

    93
  • Joined

  • Last visited

Everything posted by digman

  1. Yes, Custom bone shapes are used all the time, I would not want to animate without them other than a more simple animation plus bones can be hidden on other layers and how you can have extra bones to drive the IK and FK through the use of constraints. I mentioned all the above facts several times. My rig as stated was a rig just to work through the first problems encountered of getting the correct bones to export and the correct orientation of the rigged model for animation. In my last several post, I stated there could be some more problems to work through and suggested downloading and te
  2. Ah yes, one should never assume concerning the centering of the objects for the exported as I did. The problem just could have been simply that the creator of the model had not set the transformations as I explained earlier whether it is was set for world center or set somewhere off world center. Rigs can get complicated for sure but I have no new information to give you at this time per my previous suggestions.
  3. The disappearing of my model was happening on my end as well just did not mention it as I do like to mention problems till I can give you complete information. Also the disappearing just could be a Leadwerks bug. I figured out that the static model from BlendSwap problem I was having was based on the creator of the model. I will explain. I tested this model the other day... The blendswap model was not importing into Leadwerks with the correct Z forward orientation plus they were sometimes facing incorrect as well. In Blender when you are in Object mode(not edit mode) and you transf
  4. In the above post, I found one area to correct if possible. The below is just my final thoughts on the exporter. First, alrusdi creating an exporter is not easy job with all the variables in Blender. I would hope that after the general release that Josh will retain you for further development of the exporter. Now for the reason of the above statement. With all the available rigs and static models for blender with various users creating them plus users importing models into blender, I know there will be more problems encountered. I have tested a few rigs and static models, some have pr
  5. I am getting too busy to test much more. I did notice now though that the imported models both static and animated need their normals recalulated in the model editor for them to recieve the scene lighting correctly. Recalculating for the static models is not a problem but can cause some problems with animated models. Shown in my uploaded picture. Now the male model was imported into Blender, so I do not know if it is the reason for the mesh tearing after recalculation or not. You would have to test some animations with models created inside blender. Blendswap is a great place to get b
  6. Z Forward axis direction of the model's facing is fixed on my animated model per your last post. Ok, other than this last one static model axis direction facing problem, I think your are pretty much ready for release. I do need though to remind everyone I am only one tester and have reported most of the problems here in this thread. I of course could keep testing but like any software you could test till the cows come home and still when a large number of users use the exporter, there could be a few bugs found but hopefully very, very few. Airusdi, you have done a very good job here an
  7. Busy over the weekend but will test as soon as possible... thanks for the update... Edit : I did a quick test, The model now plays correctly in the model editor. It appears no control bones are imported. The axis is now correct but the animated model is facing -Z forward instead of Z forward. I am not a programmer so I will have to learn how to attached a camera to the head bone in a lua script to test if the animated player model walks backwards. This is the problem we had when I was working on the Phobia game which I had to leave because of health reasons. We had to export the anima
  8. A heads up for the Admin... When you click on the store in the top headers, you are taken to the forums page.
  9. digman

    Imagination

    Imagination... The brain's greatest asset... Whether creating a game engine as Josh has done, programming or creating a game plus artwork in general, imagination is the most basic nature of a human being.. This 3D WIP humanoid concept started out as a 3D sphere and evolved into what it is now at it's present stage... Artistic direction is what we need in a game or piece of art to keep us on track but it is always first from our imagination... What you see, you can create!
  10. Lets not jump to conculsions so quickly... The store could be offline for any number of reasons, The services that collects the money, has problems or updating this section of the website with a new collection service. I think Josh would give a heads up if everything was going to steam as is it would effect us here who have the standalone version. Josh is pushing steam of course with his current vision of creating a community of users sharing resources through the workshop. It's not a bad idea, he has to make money and steam can be a big revenue generator. I just rather take a
  11. Yep, first the beta has to be tested by the steam beta testers, then it is given to the regular steam leadwerks users to see if a larger group of users encounter any bugs and last of all us Standalone user gets the final compiled new version. So far I seen Josh give at the most a couple days notice on a possible release for the standalone updated version barring any unexpected bugs appearing. I consider this normal behaviour for a developer...
  12. It appears that 1-4 are all solved now... I will test some more but so far so good. --------------------------------------------------------------------------------------------------------------- Now moving on to a more complex rig animation and the problems encountered there... Problem 1: The exporter exports the control bones just not the deformation bones attached to the mesh vertices. These control bones are not needed in the exported file as no mesh vertex information is written for them. They are just control bones and it's normal to have these in a rig for animating purposes. Most
  13. This will go with my other posted report a few hours ago. I went ahead and did a complete clean install of Leadwerks. Same problems. I am still running Ubuntu 12.04 LTS and not 14.04 as I waiting on the official release update for 14.04 through the update manager. As stated in other posting I could do it through the terminal but rather wait. Maybe the cause of some problems. An update: If I select "all actions" in the exporter options then the animation is exported. Now this could be because I opened the action editor and it creates a default action which now needs to be exported. Nex
  14. Linux Blender 64 bit, 2.70A First, I got the animations working correctly but then at times exporting the same animation to a different folder the animation is not exported. Also I have to reapply the material mat before the model picks up on the scene lighting. I can not though make this an official bug report as Linux Leadwerks has a a few possible bugs that have been reported. When the new Linux update is ready I will retest to see if is a leadwerks problem or a exporter problem. I think by that time the addon will be released but testing can still happen of course. FBX ani
  15. Linux Blender version 2.70A. I am aware as you stated that real keyframes are not being written. I am going by the animated sequence numbers in the model editor. When I use step=1 the sequence numbers are the same as my animation keyframes. When I use step=2 the sequence numbers are halve. Question... Does that mean that every other keyframe in my animation is not being written to the bone matrix info or is it just an internal optimizing of the keyframes for the full matrix info for each bone or in other words a form of interpolation to reduce overhead. What do you consider a lon
  16. First, thanks for replying to these reports... About texture placement This was a user error on my part. My user created files appear when I navigate to the Documents / Leadwerks / MyGame / Models folder. I was by mistake navigating to the install folder of Leadwerks instead. Leadwerks writes to the Documents folder your user created folders and not the install folder. Your relpy made cause me to think ok what is going on here, I knew about the documents folder but had a memory lapse... "About Specularmap" I am not quite sure what you are asking here... I uploaded an image to show
  17. Test 2: I noticed in the exported material file when using the Blender exporter, that the exporter puts the specular map in Texture slot 4 after the displacement slot instead of slot 2 which is the specular texture slot in Leadwerks. In order to test this I renamed the texture files to Color \ Normal \ Specular in Blender. In Blender the files are setup correctly. Blender sees them as color, normal and specular maps respectively. Image included of the material mat file created by the exporter. I also included the blend file with the textures packed into the blend file. Let me know i
  18. 2.70A Blender Linux version, 64 bit. Default Blender Render (not Cycles) Everthing appears to be working correctly in the exporter as far as exporting the model and texture files. I included a image of the files that are exported (bottom image). I left the texture names at Blender's default. What appears not to be work correctly is that the exporter only sees the default model folders under "My Game\Models" Any added user model folders do not appear. You can not export directly to a user created model folder created under Leadwerks. This could be working in Windows but does not seem t
  19. No problems in the Linux version of Blender 2.70A. I add the folder titled "io_scene_leadwerks" under Blender's Scripts / Addon folder. The Leadwerks exporter is there in the export options. Test tommorrow on how it works...
  20. Yes, I posted about the bug in this dual bug report which included the refresh problem. It effects the Linux standalone 3.1 version as well. http://www.leadwerks.com/werkspace/topic/9869-linux-31-standalone-newest-update-auto-material-creation-not-working/ "Second bug: The asset new folder I created is not refresh anymore as well. I have to select another model folder and then return to the folder I created to see the model and texture files in the asset new folder's window. This was not the case before update."
  21. A Linux milestone for Leadwerks! Hard development work got you there...
  22. Today after installing a complete clean install of Leadwerks 3.1 Standalone Linux, I downloaded the Phobia project. Ran the Project and was getting the solid vertical sync 60 FPS. I changed one light color and reduced the bump extrusion on one normal map under the normal map texture editor window. After saving the map locally on my hard drive then running the project, (not debug) FPS was cut in half again. It was 30 FPS. I followed the same workflow as stated in my first post. It appears that saving a map for some reason causes the FPS to drop. This is all the current information I have
  23. digman

    Blender Character Rig

    The problem with rigify is the amount of bones it has after you generate the true rig from the meta rig. The WGT bones, you are advised to delete after generating the rig. Unity advises this course of action. Tearing apart a pre made complex rig can be done but seems like it would lead to headaches. Blender's rigging is not bad and I tried a few. Person opinion here, Rigify is great for regular animations for which is was created for.
  24. The animation pipeline continues to established. This time using Blender's animation tools and the rig I created to make a walk cycle. We needed to start testing some animations in Leadwerks. Rick will test soon and according to his information we can find tune and figure out any problems. The rig has only the control bones now showing. Next is to create the control shapes and those will hide the control bones. I am glad the old days of just having paper manuals is history. Manuals are good but Youtube with tons of Blender tutorials really helps. Yes you have to hunt and peck thro
  25. The models I tested have single materials... It is just a bug or drivers, it appears to be.
×
×
  • Create New...