Jump to content

FoxMulder

Members
  • Content Count

    26
  • Joined

  • Last visited

Community Reputation

0 Neutral

About FoxMulder

  • Rank
    Member
  1. HI Aggror ! Thanks for your willingness I'll send you the code via pm
  2. I can't find any part of the flashlight script conflicting with other scripts...
  3. Thank you guys, I'll check if there are other scripts conflicting!
  4. Hello everyone, I was working on a premade LUA script of FPS and I found flashlight script, really nice However I can't make it work in my personal project. I used this part of the script which is completely correct: --Flashlight if window:KeyHit(Key.F) then self.sound.flashlight:Play() if self.flashlight:Hidden() then self.flashlight:Show() else self.flashlight:Hide() end end The flashlight works, the sound is correctly played, however when I hit again the F key the flashlight doesn't turn off but the light becomes brighter and brighter. Before After What am I missing ? Thank you again for your precious support !
  5. Thank you everyone, I've managed to make the Mixamo models work ! I reinstalled the shaders from the .dae zip pack instead of the .fbx file and they perfectly work ! Thank you again !
  6. Thank you very much guys ! I'll try and I will let you know !
  7. Thank you Nick Ace ! Well I knew they are completely different but I wanted to know if there's a function to activate SetAnimationFrame when I use a certain input. This is my question
  8. Hello everyone, I'm a newcomer to Lua and Leadwerks. I have imported a premade animated model into Leadwerks in FBX format. It works perfectly however I can't find any reference about activate animations through LUA scripting. E.g. I would like to make a character walking forward on W KeyHit. All tutorials I've found till now are about C++.. Can anyone help me?
  9. Hi again, I was watching the video and I found many interesting infos about animation. However, even if my model has the correct animated shader and a animation test script attached, the animation doesn't work.
  10. Thanks YouGroove ! I only needed to update the material ! Now it works correctly... However the animations do not work yet.
  11. Hi YouGroove, thanks for your quick replay. Can you be more precise and provide a little explanation ? Thank you
  12. Hello everyone, I've got a problem using a Mixamo animated model in Leadwerks. The model is correctly exported in FBX and after imported in Leadwerks, however the engine can't find the textures and the animations don't work.. I'm using a TPS template and the character stays still in T position, even if it is correctly moving forward and backword on my key input. How can I activate the animations using key input? Thank you !
×
×
  • Create New...