Jump to content

2ima

Members
  • Content Count

    9
  • Joined

  • Last visited

Community Reputation

1 Neutral

About 2ima

  • Rank
    Newbie

Recent Profile Visitors

1,766 profile views
  1. entity mass is 50, Physics Mode and Character Physics is set properly, 'normalizedmovement' X & Z values is set and working... maxaccel is maximal acceleration to disable enitity's element race. The thing is in what when I try to use constant values instead all of those still nothing
  2. using reference i found how to make entity movement and got such: move = window->KeyDown(Key::W) - window->KeyDown(Key::S); strafe = window->KeyDown(Key:) - window->KeyDown(Key::A); //Making sure that movements is normalized so that moving forward at the same time as strafing doesn't move your character faster normalizedmovement.z = move; normalizedmovement.x = strafe; normalizedmovement = normalizedmovement.Normalize() * movespeed; //Adjust and set the camera rotation playerrotation.x += mousespeed.y*sensitivity / 10.0; playerrotation.y += mousespeed.x*sensitivity / 10.0; ent
  3. Thanks for help, I'll try to fix later. I think it's really because of model reloading.
  4. Here how it looks before animation starts, and after it becomes like I posted upper. I think somthing wrong with context sync or blend mode, but none of it helps. Runnable example means post here .exe?
  5. Standart crawler.mdl model
  6. /////////////////////////
  7. model_path = "G:/342/fff/Models/Characters/Crawler/crawler.mdl"; model = Model::Load(model_path); model->SetAnimationName(1, "Run"); std::cout << "Animation: " << model->GetAnimationName(1); anim = 42; std::cout << "*******animname***: " << model->animationname[1]; model->SetAnimationFrame(Time::GetCurrent() / 100.0, 1, 1, 1); model->Update(); Here's a problem: animation draws incorrectly, somebody knows how to fix it?
  8. Need to finish somth quick cause game is too far from finish GL everybody
  9. The thing is: how can I use a variable in one script stated on other script in lua? On example: I have 2 scripts: fps_gun.lua with a variable of ammo_count and a script App.lua with a variable named ammo_ammount. How can I use a ammo_count in App.lua(4example ammo_ammount=ammo_count) Thanks beforehand!
×
×
  • Create New...