Jump to content

randomdude

Members
  • Content Count

    70
  • Joined

  • Last visited

Everything posted by randomdude

  1. All bones need to be connected, you only assign the meshes to the related bones. The hand or finger is a different mesh with its own bones and animation. you can make them together but than you can not switch the weapon. try this tutorial.
  2. Hey man, roughness and metallic is used in PBR, LW does not support it therefore you cant use the effect. roughness means the factor by which the light is sucked up by the surface, while metallic is the reflection value. As far as I know parallax is used as a sprite for example to make distance buildings etc. that moves itself independent from the camera like a gif. or something. I think you maybe want to use the parallax as a sort of an reflection image instead of the light, like an ambient color sheme, so its reflecting the color information instead of the light. Anyway you have to hardcode it into the sourcecode or write a shader that does that. The pre-PBR way was using an ambient occlusion texture which does the trick of the light reflection which is supported. I case you dont know, you can generate that with software from your diff. textures. I use the "insane bump" plugin for GIMP but there is better paid software. but you could give it a try for testing purposes. Greetings
  3. I dont know what you are talking about but in case you try to use the load animation function, you need the same bones on both models to transfer animations from one model to another.
  4. Die FPS sind doch gut bei mir. Aber versuch mal alle Lichter auf static zu stellen. Wenn die auf static-dynamic-buffered stehen, bekommt man krasse Performance Probleme hab ich gemerkt. Keine ahnung es stürzt immer ab irgendwie.
  5. I checked the animation load function with LW 4.4 and its working perfect. So this is actually a bug.
  6. Hey, you have different grid sizes. make right-click and increase/decrease gridsize.I works per each window. so do this for the other one(s) as well. Greetings.
  7. Hello, there is a major bug in the modelviewer. I could load animations between characters with the same rig back and forth, now it gives out an exception_access_violation error and LW closes. I´m using LW 4.5 beta. Thank you. Greetings
  8. Cool stuff. weapon handling is really well done and satisfying.
  9. German is correct as well.
  10. randomdude

    why 99

    It was an idea by the ALDI-Brothers, when they have overtaken their family store, they diceded to make all prices like this so people think its cheaper. They are big players until now and this trick made them super rich. So everyone copy and pasted it.
  11. And to the thread itself, any model has this root point. so you need to set this point higher. That is where the model is placed as far as I understand it.
  12. Sorry for hijacking this thread but if Josh says something like "new editor", I think I want to add something. Its just a recommendation. The good ol´hammer editor had this baby here. https://developer.valvesoftware.com/wiki/Hammer_Vertex_Tool At the moment, the shapes and operators are not enough to make any shape. for example roofs. The other benefit is, back in my days we had FPS problems as well, so to maintain a good performance we used triangles in combination with this tool. for example rockformations, uneven grounds etc. what kept perfomance high and allowed much more varieties. To come to an end, I just want to say, this tool is very useful and should be added.
  13. I acutally played it. Has some cool mechanics. The death sound of the rat-things is really funny.
  14. He already posted the script but the update deleted his work.
  15. Depends on what you want to do. Monsters, Animals, Humans? Humans is quite easy with mocaps and makehuman. Rest I dont know.
  16. Hey man, if you download this guy here, you see it has seperate models. like the arms, legs and head are a model and the clothes are two seperate rigs. https://opengameart.org/content/mudeater-animated I saw this in a lot of games that they seperate the arms and legs and body to change it. you could try to play around with it. The other point if it is just another shirt, simple change the texture. this load.animation works very well but only if you have two identical rigs and it uses all bones. it should work if you have two upper cases with the same rig.
  17. I actually have no problem, I wanted a map as a background so that I dont have to use MS Paint skills. =D --if gamemenu:Hidden() then --Update the app timing Time:Update() --Update the world world:Update() --end I put both commands into the gamemenu:show function it has the same effect as the pause.time command commented out. gui:GetBase():SetObject("backgroundcolor",Vec4(0,0,0,0)) This thing here is like a layer that lies above the actual map. but even if would work, I think thats what einlander says, it is affecting all menus so if it wouldnt stop the startmenu map it will not stop the playing maps as well what is not such a good idea. So either I need to code a only startmenu menu. or I have a broken game. so I leave it and take the "screenshot" version. I have full colours so thats fine. I could make it map look like I did this stop on purpose what looks cool than. Anyway thank you guys.
  18. I´m sure everyone had this problem at the beginning. So use the things you learnt and do it better there is nothing to shame for. I make a video tomorrow on how to make better maps. I messed my first map up es well, for me it was the door coding. I wanted doors, so I took this door script from workshop and changed stuff in the main.lua, in the fpsplayer.lua. In the end, nothing worked anymore and I had 10 fps. So I gave up on that. Sounds familiar, doesnt it? =)
  19. Sorry to say that but your map is a mess, it has more errors than the engine is complaining. To make it proper you need to do the most stuff again anyway. If I look at the screenshots, you made a lot of mistakes that should be corrected. You overlapping your brushes everywhere, you not textured them correctly, you probably made wrong carving operations what cause access violation and yeah coding, I´m bad at coding so I stick to do making minimal changes. I had this mass error as well but I really cant remember what I did to solve it. I invested 200 hours in my first map and I think today its a big pile of mistakes and errors. I made much better stuff since I quit working on that, so maybe you see it as a learing experience and make a new project. you can export your terrain and load it into your new project. so you dont need to do this again. you can also save some of your structures as prefabs and place it on the new project. I dont think you can transfer this into another engine.
  20. Hey man, the forumupdate delete my old post. I think this function here is the reason. gui:GetBase():SetObject("backgroundcolor",Vec4(0,0,0,0)) If commented out the screen turns grey. so if we could manipulate the size of it, it should work. Time pause is only called once in the script, if commented out you hear sound. but this other function is over it so you still have a "screenshot".
  21. Good news, I thought I try it anyway and it is working. Main.lua -Create a world world=World:Create() Map:Load("Maps/Start.map") local font = Font:Load("Fonts/Arial.ttf",10) context:SetFont(font) and Menu.lua elseif event.source == self.newbutton then if self.newbutton:GetText()=="NEW GAME" then world:Clear() if Map:Load("Maps/NMLVL01.map") then Okay so but how do I get rid of the Time pause in the start menu? so that the map is played?
  22. try to load a backup maybe? the backups located for me in documents/leadwerks/backup.
  23. Hello, where do I load a map as a background for the startmenu?
  24. No it´s not working. https://www.twitch.tv/videos/172707074 It´s not only not working it causes graphic errors. I stick to my trigger version.
×
×
  • Create New...