Jump to content

wdna

Members
  • Content Count

    20
  • Joined

  • Last visited

Community Reputation

1 Neutral

About wdna

  • Rank
    Member
  • Birthday 02/08/1984

Profile Information

  • Gender
    Male
  • Location
    Israel
  1. I now have both Ubuntu and Gentoo (replaced Arch) also over here. I got the Lua (3.3) editor working via Steam, but with bad interface. and looks like I have the same issue Kobnar showed with with fault. Did anyone of you managed to run the C++ version on Gnetoo? if yes post the package list used to emerge. What's nice about Gentoo is that you can create overlays for portage, we could me a Leadwerks overlay if some package setting would work. What would be even nicer is a 64-bit version of the editor, won't need all this 32-bit **** in my system.
  2. Maybe try strace+dtrace it? would that be possible?
  3. That is indeed not a desirable dependency Hope you solve it. I run Arch, not sure if I can run Leadwerks on it -- I'm running Leadwerks from a temporary Ubuntu 14.04 install on another SSD. so replacing it with Gentoo would be a real joy. following this topic.
  4. wdna

    Tutorials on C++?

    There's also this
  5. wdna

    other distros.

    Hay, as Arch user I can advice you not to use Manjaro, consider installing Arch Linux or some other distribution.This Linux is kind of broken because the guys Manjaro don't really know what they are doing. I can tell you Arch can run for example all Linux Steam games without any issues if this is your concern.
  6. This is not directly related to Leadwerks. It seems although you have internet connection you getting NOT FOUND 404 messages from that site. Did you make any repository configurations on your Ubuntu? maybe try a mirror of this repository?
  7. This is a nice place to begin with: He has nice tutorials for C++ beginners.
  8. Thanks! This worked for me! ship = Model::Load("Models/Ship/dark_fighter_6.mdl"); ship->SetPosition(0,4,0); shipPivot = Pivot::Create(); ship->SetParent(shipPivot); ship->SetRotation(90,90,0, true); ... if(window->KeyDown(Key::A)) { shipPivot->Move(-move_speed,0,0); } ... There's some pattern to handle this in more global manner?
  9. I found a free model I can play with of nice quality. I have the following situation: Like you can see the models initial rotation is wrong, it should be facing the direction of brush. This code can fix the rotation for me: ship->SetRotation(90,90,0, true); But then I have issue with ship movement: if(window->KeyDown(Key::A)) { ship->Move(-move_speed,0,0); } if(window->KeyDown(Key:)) { ship->Move(move_speed,0,0); } if(window->KeyDown(Key::S)) { ship->Move(0,0,-move_speed); } if(window->KeyDown(Key::W)) { ship->Move(0,0,move_speed); } Movement would be in the wrong then directions. I could also adjust this but obviously it's not the right way. I am aware you can rotate it in some 3D software like blender, but I'm trying to avoid it right now. and generally what would be best practice for such cases?
  10. wdna

    Non-buntu distros

    If you know well your operating environment it should be possible to run Leadwerks probably under most distributions. Gentoo is very flexible - you should be able to run Leadwerks one way or another. I'm an Arch user my self, but I installed Ubuntu 14.04 on another drive for running Leadwerks. I advice to do the same, Leadwerks and Linux games in general still require 32-bit libs to be available in system, I figured I'll need to install some 32-bit libs on Arch to get Leadwerks running so I preferred installed a 'sandbox' Ubuntu instead. Nevertheless, I also would like to see more distributions supported in the future.
  11. Josh, Toaster, found the issue, I replaced: <Variable name="LeadwerksPath" value='"/home/wdna/Leadwerks"' /> with: <Variable name="LeadwerksPath" value="/home/wdna/Leadwerks" /> Looking at other definitions in project, this seemed a bit strange to set value like that with the '"' escape. Now everything works fine and I can view the source files. Like mentioned, it would be nice if this libraries will be auto added upon new projects: <Add library="pthread" /> <Add library="X11" />
  12. Yes, that seems to be the the case: <Environment> <Variable name="LeadwerksPath" value='"/home/wdna/Leadwerks"' /> </Environment> I'm starting to think this is some kind of Code::Blocks bug? By looking at build configuration, without this variable compile should not work, but it does.
  13. Yes, I opened the files from ~/Documents/Leadwerks/Projects/Test/Projects/Linux with Code::Blocks -- this was generated by creating new C++ project.
  14. Although my project compiles after I added 'pthread' and 'X11' to linker in build options, the Code::Blocks IDE is unable to find the declarations of the 'Leadwerks' namespace. For example: window = Leadwerks::Window::Create("MyGame", 200, 150, 1024, 768, Leadwerks::Window::Titlebar); When pressing LMB on 'Create' and choosing "Go to deceleration ..." the action results an error. My version of Code::Blocks is 13.12, the default install on Ubuntu 14.04. I did not find any 'special' way to add the files to IDE, their path is clearly in the include. Should I add what's inside /home/myuser/Leadwerks/Include/ to the project files or anything like that?
  15. I can confirm it worked for me as well. Using brand new install of 14.04 beta. Also needed this as dependency: libjson-c2 i386 0.11-3ubuntu1 libasound2 i386 1.0.27.2-3ubuntu7 libasyncns0 i386 0.8-4ubuntu2 libogg0 i386 1.3.1-1ubuntu1 libflac8 i386 1.3.0-2 libvorbis0a i386 1.3.2-1.3ubuntu1 libvorbisenc2 i386 1.3.2-1.3ubuntu1 libsndfile1 i386 1.0.25-7ubuntu2 libwrap0 i386 7.6.q-25 libpulse0 i386 1:4.0-0ubuntu11 libopenal1 i386 1:1.14-4ubuntu1
×
×
  • Create New...