Jump to content

Search the Community

Showing results for tags 'editor'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Categories

  • Models
    • Animals
    • Barriers
    • Characters
    • Containers
    • Environments
    • Furniture
    • Props
    • Rocks
    • Vegetation
    • Vehicles
    • Weapons
  • Materials
    • Brick
    • Cartoon
    • Decals
    • Dirt
    • Grass
    • Industrial
    • Medieval
    • Metal
    • Plastic
    • Plaster
    • Rock
    • SciFi
    • Sky
    • Signs
    • Tile
    • Stone
    • Walls
    • Wood
  • Plugins
  • Scripts
    • GUI
    • Object
    • Utilities
  • Shaders
    • Post-Processing Effects
    • Surface
  • Sounds
    • Ambience
    • Effects
    • Music
  • Tools
  • BATTLE LEAGUE's Assets
  • BATTLE LEAGUE's Mods

Blogs

There are no results to display.

There are no results to display.

Forums

  • Leadwerks
    • Technical Assistance
    • General Discussion
    • Programming
    • Game Art
    • Suggestion Box
    • Bug Reports
  • Platforms
    • Windows
    • Mac
    • Linux
  • Community
    • Showcase
    • Promotion
    • Off-topic
  • BATTLE LEAGUE's Topics
  • Vec-Tec's Releases
  • Vec-Tec's Topics
  • Forth's Development
  • Forth's Game design
  • Forth's Graphics
  • Forth's Documentation
  • Forth's TODO
  • Forth's IMPORTANT
  • Forth's Screenshots
  • The uncertain world's Game Design
  • The uncertain world's Programming
  • The uncertain world's TODO
  • The uncertain world's Graphics
  • The uncertain world's Screenshots

Categories

  • Records
  • Entity
  • Command Reference
  • Vec3
  • Vec4
  • Script Reference
  • Shader
  • Index
  • Material
  • Object
  • Buffer
  • Asset
  • Font
  • Shape
  • Sound
  • Texture
  • App
  • Context
  • Model
  • Light
  • DirectionalLight
  • PointLight
  • SpotLight
  • Attractor
  • Camera
  • Emitter
  • Listener
  • Pivot
  • Bone
  • Sprite
  • FileSystem
  • Key
  • Source
  • Surface
  • Math
  • AABB
  • dVec3
  • Mat3
  • Mat4
  • Plane
  • Transform
  • Vec2
  • Vec3
  • Vec4
  • Mutex
  • Prefab
  • PickInfo
  • Map
  • Stream
  • System
  • Thread
  • Time
  • Window
  • World
  • Driver
  • SoundDriver
  • GraphicsDriver
  • PhysicsDriver
  • OpenGL2GraphicsDriver
  • OpenGLES2GraphicsDriver
  • OpenALSoundDriver
  • NewtonDynamicsPhysicsDriver
  • Draw
  • Color
  • Blend
  • Joint
  • Debug
  • Component
  • Steamworks
  • LensFlare
  • Vehicle
  • Decal
  • Quat
  • Leaderboard
  • Probe
  • Analytics

Categories

  • Games

Product Groups

  • Software
  • Gear

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location


Interests

Found 64 results

  1. Hi All, I have a door frame and door model that I'm creating a prefab from. Both the door and frame models are larger than required, so inside the editor I dragged both objects into my world and applied a scaling factor to them. Then I dragged the door into the frame group, this all worked fine. However, when I attached the swinging door script to the door and activate it in game, the door goes back to the original scaling factor. I can solve this by scaling the models and reimporting them, but is this a bug because surely it obey the scaling factor as seen the in the WYSIWYG editor?
  2. This is using today's update. In the editor for example, the scripts folder you can see all the scripts and shaders of all the child folders instead of just the files in the current folder. I'm at work so I can't take screenshots.
  3. Steps to reproduce ; Tools > Options Under editor Font will say <None> click and select "DejaVu Sans Mono" 12pt Click ok Now re open the Menu Tools > Options and the entire editor crashes Other fonts gives different results - "Tlwg Typist" font instance sometimes causes an instant crash and some times you can repeat the above steps 10 times before it crashes. At first I suspected font with spaces in the names but even one word ones sometimes crashes.
  4. Hi, really weird but I came home from vacation and suddenly I can not pan, change camera direction, WASD keys not responding, holding middle mouse button and right mouse button not responding. I can not debug in editor. It opens the window but nothing happens. Tried to delete leadwerks and reinstall, same problem. I am kinda lost on this.
  5. I apologize if this has been asked before (I tried searching, but nothing useful has come up). Anyway, in the editor after I updated Leadwerks, I get this error repeated many times. Basically, my whole scene in the editor has no shadows. Error: Uniform "shadowmapsize" is not a vec2 value. Am I doing something wrong? (I'm not sure if this is bug or a new "feature"). Note that it does work in game with the same shaders and such (except DOF, but i doubt that has anything to do with it).
  6. When editing an objects position, rotation, or scale from the General tab of the editor, it would really be nice to be able to copy and paste vectors instead of each axis individually.
  7. Sometimes prefabs turn invisible for me and are unable to be picked in the editor. I attached an example that contains just CSG. I'm not entirely sure how to reproduce this as it happens in a kind of random manner, but maybe you can spot something wrong in the attached file. Thank you. square.zip
  8. Hello, we are experiencing a quite critical bug that concerns the scene browser, it for some reasons stops drawing new entries and just displays a large white area. This occurs on the latest steam and standalone build, tested on multiple computers. We are hoping for a fast fix as this basically stops us from working on the level design. Here is a picture of the problem: Thank you!
  9. Quick question, what is the execution order of Lua scripts? For example, if I have a scene with 3 entities with Lua scripts, is the Lua script of the entity that is listed first always called first? I apologize if this is a repeated question since this sounds pretty basic, I tried searching but I couldn't find anything
  10. Ok so I've decided to make my own project to practice on learning how to use the engine. In the sample project 'MyGame', the camera placed using the editor had wireframe showing the viewing frustum. But in my new project when I add a camera using the editor, the frustum is gone. How do I make the frustum reappear? EDIT: Huh I restarted the editor and the camera got its frustum back.
  11. Hello, since the last update the camera clipping range in the editor is too low. We are not able to work efficiently on our level with a size of 2048x2048 as some parts of the level are always clipped. Please increase it or make it an option in the settings dialog. Cheers, Bryan
  12. Hello, when calculating the angular threshhold on on of our models the editor just crashes with EXCEPTION_ACCESS_VIOLATION. The .mdl file is attached. Thank you! Car_02_regrouped.mdl
  13. Hi, I'm new to Leadwerks 3 and I would like to get some help with Terrain painting. My problem is that, when I select the painting tool in terrain editor and I click on a layer, nothing happens, can't paint the terrain. The only thing I can do is to select minimum and maximum slope and height for every layer (texture) and when I sculpt the terrain it change the layer (texture) at some point, but as there is a painting tool to choose I think we can paint the selected texture on the terrain somehow but I don't know how and also can't find tutorials. The only tutorial I find is for Leadwerks 2.x but the terrain painting just don't work that way in v3.2 as I can't choose (assign) layer to paint. Anybody could help me please? Thanks.
  14. After uploading my first lua snippet i'm continuing my task to develope useful tools for Leadwerks Engine. What tools you may ask? The first, a batch texture converter is ready since a long time, but needs some tweaking here and there. A beta was previously published but i want to get this tool out of the beta and will release a finished version the next days. The next one is to finish my milkshape exporter (animations still doesn't work) but the rest is faster and less buggy. The main tool I'm currently developing is a small helper which i call "Asset Helper". What does this exactly mean? Well everyone who ever have bought a model pack from one of the modelshops around the web may know this problem. You download it and want to play with it in the Leadwerks Editor. Unfortunatly in most cases this doesn't work at first. You need to: -convert the model to the gmf format -create correct material files -create lua scripts -give proper names to have a good structures view in the Editor -and some things more / depends on the pack What does my tool do? In a first version of my tool I tried to do the above steps completely automatically with just a parameters given at startup, but this aproach fails as expected. It was working with some modelpacks but mostly it fails. So my new approach is a semi-automatic tool: First it will scan and analyse a given directory recursivly and collects all needed data like available models, are there already GMF models or do we need to convert from fbx. It collects every texture it found and like the GenMat tool it will try to find proper texture pairs to build material files. In a last prestep it will scan the converted meshes and get the needed materials or marks missing materials. The next step is done by the user: Choose which models to pack into the asset library. Assign missing textures, rename them etc. . You will also be able to choose a scale value for every single model or choose a scale for all models. The analyser will also attach a basic lua file to each model so you have proper dialogs in the editor. The last step will be to choose an asset name, a package name (optional) and a password (also optional). After a click on start the whole process will start and you will get a nice pak file or a directory structure which you only need to copy into your Game folder. I hope that I have a small Update next time, maybe a screenshot. See ya, klepto2
×
×
  • Create New...