Jump to content

Search the Community

Showing results for tags 'debug'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Categories

  • Models
    • Animals
    • Barriers
    • Characters
    • Containers
    • Environments
    • Furniture
    • Props
    • Rocks
    • Vegetation
    • Vehicles
    • Weapons
  • Materials
    • Brick
    • Cartoon
    • Decals
    • Dirt
    • Grass
    • Industrial
    • Medieval
    • Metal
    • Plastic
    • Plaster
    • Rock
    • SciFi
    • Sky
    • Signs
    • Tile
    • Stone
    • Walls
    • Wood
  • Plugins
  • Scripts
    • GUI
    • Object
    • Utilities
  • Shaders
    • Post-Processing Effects
    • Surface
  • Sounds
    • Ambience
    • Effects
    • Music
  • Tools
  • BATTLE LEAGUE's Assets
  • BATTLE LEAGUE's Mods

Blogs

There are no results to display.

There are no results to display.

Forums

  • Leadwerks
    • Technical Assistance
    • General Discussion
    • Programming
    • Game Art
    • Suggestion Box
    • Bug Reports
  • Platforms
    • Windows
    • Mac
    • Linux
  • Community
    • Showcase
    • Promotion
    • Off-topic
  • BATTLE LEAGUE's Topics
  • Vec-Tec's Releases
  • Vec-Tec's Topics
  • Forth's Development
  • Forth's Game design
  • Forth's Graphics
  • Forth's Documentation
  • Forth's TODO
  • Forth's IMPORTANT
  • Forth's Screenshots
  • The uncertain world's Game Design
  • The uncertain world's Programming
  • The uncertain world's TODO
  • The uncertain world's Graphics
  • The uncertain world's Screenshots
  • Muerte's Discussion

Categories

  • Records
  • Entity
  • Command Reference
  • Vec3
  • Vec4
  • Script Reference
  • Shader
  • Index
  • Material
  • Object
  • Buffer
  • Asset
  • Font
  • Shape
  • Sound
  • Texture
  • App
  • Context
  • Model
  • Light
  • DirectionalLight
  • PointLight
  • SpotLight
  • Attractor
  • Camera
  • Emitter
  • Listener
  • Pivot
  • Bone
  • Sprite
  • FileSystem
  • Key
  • Source
  • Surface
  • Math
  • AABB
  • dVec3
  • Mat3
  • Mat4
  • Plane
  • Transform
  • Vec2
  • Vec3
  • Vec4
  • Mutex
  • Prefab
  • PickInfo
  • Map
  • Stream
  • System
  • Thread
  • Time
  • Window
  • World
  • Driver
  • SoundDriver
  • GraphicsDriver
  • PhysicsDriver
  • OpenGL2GraphicsDriver
  • OpenGLES2GraphicsDriver
  • OpenALSoundDriver
  • NewtonDynamicsPhysicsDriver
  • Draw
  • Color
  • Blend
  • Joint
  • Debug
  • Component
  • Steamworks
  • LensFlare
  • Vehicle
  • Decal
  • Quat
  • Leaderboard
  • Probe
  • Analytics

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location


Interests

Found 7 results

  1. iI have error in debug , see the image , someone help please
  2. Spent ages trying to figure out why a certain line of code keep breaking the program. After deciding to restart Leadwerks I reopened the script file and suddenly there was a break-point at that line. I did remove it before hand, but it obviously just removed the icon, not the actual break-point. Hope this can be resolved soon.
  3. Hello, like in the tutorial the debug mode should look similar to this: But for me it looks like the attached image. The bottom tabulators "Output", "Warnings", "Errors" and "Debug" are missing. How can I enable these or maybe it's a bug? I use the actual version of Leadwerks. I'm sure that I run the game in debug mode because the main console in the Leadwerks Engine says "Debug process connected.". But nothing more. And another section doesn't exist there either. Thanks for help. Max debug_wrong.bmp
  4. I cannot find a way to 'autoscroll' the debug window text. It would be nice if it was possible to set it to 'autoscroll on ouput', so that you can easily see the latest messages that get's printed out. (Running on ubuntu, guessing it's the same on windows, but I have not tested on windows because I do not have that). It's not easy to debug when you debug 'blind' and then have to scroll down and read the output afterwards. Makes it very tricky. Also - the output window on the main editor screen - would be nice if that one also could show the same text as what the output\debug window in the script editor shows. That would make it easier\faster to debug.
  5. Whenever I attempt to Run/Debug a game the program seems to freeze up and display "(Not Responding)" in the window title bar. I have to manually close the program, or click on the Stop button in the Script editor, to return back to the Leadwerks editor. I have a Radeon HD 7870. The issue happened with both the 15.8 and 15.9 beta drivers. Not sure when the last time that it worked, as I haven't used the engine in some time, but I will attempt rolling back the drivers. Anyone else experiencing this issue? I've attached a screenshot of the issue.
  6. In the Leadwerks editor it use to have the bottom console visible by default or hidden if you hide it. Now its always hidden when you load the editor regardless of what you set it at previously. Many times I start the editor and load my map and miss all the red text telling me things are potentially wrong. I would request an option or the ability to keep the position of the editor console constant between sessions.
  7. When creating a brand new c++ project in the project manager and then opening the solution and hitting debug that the debugging session ends almost straight away. Tracing the console and debugging the (Default) application i can see that i fail on the second call to "world->Render();" The console reports GL_INVALID_OPERATION Note that no changes have been made to the default startup project. I am using visual studio 2013 Professional
×
×
  • Create New...