Jump to content

Search the Community

Showing results for tags 'flowgraph'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Categories

  • Models
    • Animals
    • Barriers
    • Characters
    • Containers
    • Environments
    • Furniture
    • Props
    • Rocks
    • Vegetation
    • Vehicles
    • Weapons
  • Materials
    • Brick
    • Cartoon
    • Decals
    • Dirt
    • Grass
    • Industrial
    • Medieval
    • Metal
    • Plastic
    • Plaster
    • Rock
    • SciFi
    • Sky
    • Signs
    • Tile
    • Stone
    • Walls
    • Wood
  • Plugins
  • Scripts
    • GUI
    • Object
    • Utilities
  • Shaders
    • Post-Processing Effects
    • Surface
  • Sounds
    • Ambience
    • Effects
    • Music
  • Tools
  • BATTLE LEAGUE's Assets
  • BATTLE LEAGUE's Mods

Blogs

There are no results to display.

There are no results to display.

Forums

  • Leadwerks
    • Technical Assistance
    • General Discussion
    • Programming
    • Game Art
    • Suggestion Box
    • Bug Reports
  • Platforms
    • Windows
    • Mac
    • Linux
  • Community
    • Showcase
    • Promotion
    • Off-topic
  • BATTLE LEAGUE's Topics
  • Vec-Tec's Releases
  • Vec-Tec's Topics
  • Forth's Development
  • Forth's Game design
  • Forth's Graphics
  • Forth's Documentation
  • Forth's TODO
  • Forth's IMPORTANT
  • Forth's Screenshots
  • The uncertain world's Game Design
  • The uncertain world's Programming
  • The uncertain world's TODO
  • The uncertain world's Graphics
  • The uncertain world's Screenshots

Categories

  • Records
  • Entity
  • Command Reference
  • Vec3
  • Vec4
  • Script Reference
  • Shader
  • Index
  • Material
  • Object
  • Buffer
  • Asset
  • Font
  • Shape
  • Sound
  • Texture
  • App
  • Context
  • Model
  • Light
  • DirectionalLight
  • PointLight
  • SpotLight
  • Attractor
  • Camera
  • Emitter
  • Listener
  • Pivot
  • Bone
  • Sprite
  • FileSystem
  • Key
  • Source
  • Surface
  • Math
  • AABB
  • dVec3
  • Mat3
  • Mat4
  • Plane
  • Transform
  • Vec2
  • Vec3
  • Vec4
  • Mutex
  • Prefab
  • PickInfo
  • Map
  • Stream
  • System
  • Thread
  • Time
  • Window
  • World
  • Driver
  • SoundDriver
  • GraphicsDriver
  • PhysicsDriver
  • OpenGL2GraphicsDriver
  • OpenGLES2GraphicsDriver
  • OpenALSoundDriver
  • NewtonDynamicsPhysicsDriver
  • Draw
  • Color
  • Blend
  • Joint
  • Debug
  • Component
  • Steamworks
  • LensFlare
  • Vehicle
  • Decal
  • Quat
  • Leaderboard
  • Probe
  • Analytics

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Location


Interests

Found 11 results

  1. Hi I added to fpsplayer.lua in UpdateWorld fonction (when a condition is true) : self.component:CallOutputs("RickRoll") So in the FlowGraph Editor i link "RickRoll" to a pivot (who have Noise.lua) on Play() The problem is when the condition is true in game the music don't start and most weirdly when i go the game menu (Escape) the music start and if i go back to the game the music stop. How can i solve this ? Thx
  2. Hi! I can't open script editor for some reason. Or flowgraph for that matter. Anyone else had this problem? I've been away for some time, but last time I used Leadwerks, it worked just fine.
  3. Hi, I've tried lots of things to make the background music change during gameplay and I'm still failing to do it properly and now getting out of ideas. I'm using the flowgraph editor to start the music when the player take ammunition and this part work correctly. The part that is failing is that when a designated NPC is killed, I want to pause the current music and start a new music. The pause of the current music works, but the new music if failing to start. I'm using NOISE.lua and modified it slightly with monster.lua to give them the output to flowgraph. I've applied the noise.lua script to 2 pivot. One for each song. Set the script for each song. I was able to make them play both by making them play at start. The second song refuse to start when the NPC is killed, the pause work, not the other song. Here is a screenshot of my flowgraph setup: The only thing I could think of now, is look at the LUA code for noise.lua and modify it to handle 2 tracks so everthing is handled in the same script. BTW, the flowgraph editor is really powerful!! Too bad we can't group items and zoom-in/zoom-out...
  4. This issue started happening since the latest update where I would load a level, and if I tested it in the editor immediately, it would work without problems, but, if I just moved a single piece of code in the flowgraph it would make the level crash when loading completely, from then on out, the level wouldn't work anymore, no matter what I did. Here's a short 2 minute video showing the problem. Things I have tried: -Re-loading the level. -Re-installing the engine. -Make a new project. I'm using the latest version of LEX 1.
  5. How do you program something to appear in the Flow Graph editor with an output and an input?
  6. Hello My problem is that I have an Pivot which has the platform.lua script attached. when I test it out and select it to be enabled at the program start, everything works just fine. The pivot with all the atttached models are moving right where I want them and at the right speed. But when I select it to be disabled at the start of the program, it just keeps locked. I am pretty sure when you are ingame you cant make it change or just start inside the game. I tested it inside flowgraph editor with multiple ways : collision, pushbotton (none of them work) It am very confused about that since the most part of the script is in update...() functions. So how do you can make it change (via flowgraph) ?
  7. I have standard edition of Leadwerks and I'm working in beta branch now (Leadwerks 3.5). After last update I have noticed a problem with flowgraph editor. My function: function Script:EnterType()--arg return self.collidedEntityType end is not reflected in the flowgraph and therefore I cannot trasmit this agrument to the input function (with --in) Only output and input methods are showed in the graph. Arguments are not. (Windows 8.1, GeForce GTX 460)
  8. So I've been trying to use this software but I've been encountering this very frustrating bug that I can't figure out. Admittedly, my experience with scripting and game editing is very limited so it is likely I've just missed something. I tried to attach a video of the bug, but the forum won't let me. I'll post it on youtube instead and leave a link. Any help would be greatly appreciated.
  9. Not the first time, the connections are lost but only at player:fpsplayermr See Yesterday. http://steamcommunity.com/sharedfiles/filedetails/?id=372487550 Today:
  10. MarkusR

    Flowgraph

    please can u add zoom or minimap and movement/scrolling with cursor keys? drag a point over a long distance is not easy.
  11. today i waste hours to find a nasty bug^^ i want use my call output "Open" with a other prefab door but it not work anymore. i just want switch light on if door opens but nothing happens. it seems the flowgraph have a problem with same names and did not find the correct object. all objects in scene tree view must have a unique id but i can not see what they internal have. i rename a object under general name and my call output work. arrrgggg. this prefab have all the same name and internal maybe the same id. (after rename it is not a prefab anymore.) please fix it
×
×
  • Create New...