Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Installing Leadwerks on Gentoo (Segmentation Fault)


Recommended Posts

I am trying to get Leadwerks to install correctly on Gentoo. I realize that only Ubuntu is supported, but that doesn't mean the program shouldn't run on another distribution.


Whenever I try to run the LeadwerksUpdater, I get a blank GTK window for a split second before it dies with a segmentation fault. No additional dbug information is provided.


Here's my "conversion" table marking packages in Ubuntu and their equivalent packages in Gentoo:

libc6:i386 == sys-libs/lib-compat (1.4.2-r1)
libgcc1:i386 == sys-devel/gcc (4.8.3)
libgl1-mesa-glx:i386 == media-libs/mesa (10.2.2)
libglib2.0-0:i386 == dev-libs/glib (2.40.0-r1)
libopenal1:i386 == media-libs/openal (1.15.1-r2)
libstdc++6:i386 == sys-libs/lib-compat (1.4.2-r1)
libx11-6:i386 == x11-libs/libX11 (1.6.2)
libxxf86vm1:i386 == x11-libs/libXxf86vm (1.1.3)
gtk2-engines:i386 == x11-themes/gtk-engines (2.20.2-r1)
gtk2-engines-murrine:i386 == x11-themes/gtk-engines-murrine (0.98.2-r1)
unity-gtk2-module:i386 == *not installed*
libdbusmenu-glib4:i386 == dev-libs/libdbusmenu (12.10.2)


I have all of the necessary 32bit/64bit emulation libraries installed on my system. As far as I can tell, I am only missing one dependency. To that end, installing unity-base/unity-gtk-module requires the unity-gentoo overlay and all kinds of system-breaking ugliness just so I can install a terrible desktop environment on my system.


If anyone knows how to get Leadwerks to run on Gentoo (or Arch or anything else that's not a fork of Ubuntu), I'd really appreciate some help.


Thanks in advance!

Link to post

That is indeed not a desirable dependency wink.png Hope you solve it.

I run Arch, not sure if I can run Leadwerks on it -- I'm running Leadwerks from a temporary Ubuntu 14.04 install on another SSD. so replacing it with Gentoo would be a real joy. following this topic.

Link to post

I feel like that's gotta be it. Everything else looks like build dependencies. I installed Leadwerks on a virtual machine running Ubuntu to get a better sense of what is supposed to happen. The updater is just a simple interface, so I don't think having an upstream version of gcc would break it. More like Canonical and their non-backwards-compatible Unity library is causing the crash.


If this website had a feature request section, I'd probably start a new thread called "For the love of the gods, don't develop anything for Unity." They could just as easily develop this sucker to work with Xubuntu or Kubuntu and it would just work on Unity anyway. Instead, they pick the only corner of Linux where the maintainer has a stated goal of doing their own thing at the expense of the users interests.


As it stands, there is no request feature ticket, and I doubt this is going to change anytime soon.


Time to start digging for the refund policy...

Link to post

AFAIK the Unity dependencies are completely optional even on Ubuntu.


When Leadwerks first shipped the installer script was trying to install a version of that unity dependency that only existed in 12.04, so I couldn't fulfill it on 13.10 either, the only thing that happened was not having a global menu.


So yeah, there is something else going wrong.

Link to post

Fist off, a public apology is due for the off-base anti-unity rant. I had a really frustrating day yesterday, took it out in the wrong place.


Here's what I've found out so far:


To clarify the problem...

$ ./LeadwerksUpdater
Segmentation Fault
$ su
# ./LeadwerksUpdater
Segmentation Fault

Again, a blank window flashes for a brief second before disappearing and throwing a segmentation fault.


I tried running ldd...

$ ldd LeadwerksUpdater
libX11.so.6 => /usr/lib32/libX11.so.6 (0xf757d000)
libXxf86vm.so.1 => /usr/lib32/libXxf86vm.so.1 (0xf7577000)
libglib-2.0.so.0 => /usr/lib32/libglib-2.0.so.0 (0xf7441000)
libgtk-x11-2.0.so.0 => /usr/lib32/libgtk-x11-2.0.so.0 (0xf6fd7000)
libgdk-x11-2.0.so.0 => /usr/lib32/libgdk-x11-2.0.so.0 (0xf6f27000)
libpango-1.0.so.0 => /usr/lib32/libpango-1.0.so.0 (0xf6edc000)
libgobject-2.0.so.0 => /usr/lib32/libgobject-2.0.so.0 (0xf6e89000)
libm.so.6 => /lib32/libm.so.6 (0xf6e44000)
libgcc_s.so.1 => /usr/lib/gcc/x86_64-pc-linux-gnu/4.8.3/32/libgcc_s.so.1 (0xf6e29000)
libpthread.so.0 => /lib32/libpthread.so.0 (0xf6e0d000)
libc.so.6 => /lib32/libc.so.6 (0xf6c68000)
libgdk_pixbuf-2.0.so.0 => /usr/lib32/libgdk_pixbuf-2.0.so.0 (0xf6c45000)
libxcb.so.1 => /usr/lib32/libxcb.so.1 (0xf6c22000)
libdl.so.2 => /lib32/libdl.so.2 (0xf6c1e000)
libXext.so.6 => /usr/lib32/libXext.so.6 (0xf6c0a000)
libgmodule-2.0.so.0 => /usr/lib32/libgmodule-2.0.so.0 (0xf6c05000)
libpangocairo-1.0.so.0 => /usr/lib32/libpangocairo-1.0.so.0 (0xf6bf8000)
libXfixes.so.3 => /usr/lib32/libXfixes.so.3 (0xf6bf2000)
libatk-1.0.so.0 => /usr/lib32/libatk-1.0.so.0 (0xf6bce000)
libcairo.so.2 => /usr/lib32/libcairo.so.2 (0xf6a96000)
libgio-2.0.so.0 => /usr/lib32/libgio-2.0.so.0 (0xf6916000)
libpangoft2-1.0.so.0 => /usr/lib32/libpangoft2-1.0.so.0 (0xf6902000)
libfontconfig.so.1 => /usr/lib32/libfontconfig.so.1 (0xf68c5000)
libXrender.so.1 => /usr/lib32/libXrender.so.1 (0xf68ba000)
libXi.so.6 => /usr/lib32/libXi.so.6 (0xf68a9000)
libXrandr.so.2 => /usr/lib32/libXrandr.so.2 (0xf689e000)
libXcursor.so.1 => /usr/lib32/libXcursor.so.1 (0xf6893000)
libXcomposite.so.1 => /usr/lib32/libXcomposite.so.1 (0xf688f000)
libXdamage.so.1 => /usr/lib32/libXdamage.so.1 (0xf688b000)
libffi.so.6 => /usr/lib32/libffi.so.6 (0xf6882000)
/lib/ld-linux.so.2 (0xf76ed000)
libXau.so.6 => /usr/lib32/libXau.so.6 (0xf687e000)
libXdmcp.so.6 => /usr/lib32/libXdmcp.so.6 (0xf6877000)
libfreetype.so.6 => /usr/lib32/libfreetype.so.6 (0xf67d4000)
libpixman-1.so.0 => /usr/lib32/libpixman-1.so.0 (0xf6736000)
libEGL.so.1 => /usr/lib32/libEGL.so.1 (0xf6686000)
libpng16.so.16 => /usr/lib32/libpng16.so.16 (0xf664d000)
libxcb-shm.so.0 => /usr/lib32/libxcb-shm.so.0 (0xf6649000)
libxcb-render.so.0 => /usr/lib32/libxcb-render.so.0 (0xf663e000)
libz.so.1 => /lib32/libz.so.1 (0xf6627000)
libGL.so.1 => /usr/lib32/libGL.so.1 (0xf650f000)
librt.so.1 => /lib32/librt.so.1 (0xf6506000)
libresolv.so.2 => /lib32/libresolv.so.2 (0xf64ef000)
libharfbuzz.so.0 => /usr/lib32/libharfbuzz.so.0 (0xf6497000)
libexpat.so.1 => /usr/lib32/libexpat.so.1 (0xf646e000)
libbz2.so.1 => /usr/lib32/libbz2.so.1 (0xf645b000)
libnvidia-glsi.so.340.24 => /usr/lib32/libnvidia-glsi.so.340.24 (0xf63d5000)
libnvidia-tls.so.340.24 => /usr/lib32/libnvidia-tls.so.340.24 (0xf63d0000)
libnvidia-glcore.so.340.24 => /usr/lib32/libnvidia-glcore.so.340.24 (0xf3e3d000)
libgraphite2.so.3 => /usr/lib32/libgraphite2.so.3 (0xf3e1d000)


Looks to me like a bunch of libraries were successfully loading. Didn't see any problems, so I carried on.


I tried running strace...

$ strace ./LeadwerksUpdater
gettimeofday({1405552049, 20109}, NULL) = 0
gettimeofday({1405552049, 20124}, NULL) = 0
gettimeofday({1405552049, 20139}, NULL) = 0
stat64("/usr/lib32/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-png.so", {st_mode=S_IFREG|0755, st_size=17912, ...}) = 0
open("/usr/lib32/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-png.so", O_RDONLY|O_CLOEXEC) = 9
read(9, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\260\24\0\0004\0\0\0"..., 512) = 512
fstat64(9, {st_mode=S_IFREG|0755, st_size=17912, ...}) = 0
mmap2(NULL, 20800, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 9, 0) = 0xfffffffff3b6d000
mmap2(0xf3b71000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 9, 0x3000) = 0xfffffffff3b71000
close(9)							    = 0
mprotect(0xf3b71000, 4096, PROT_READ)   = 0
_llseek(8, 0, [0], SEEK_SET)		    = 0
--- SIGSEGV {si_signo=SIGSEGV, si_code=SEGV_MAPERR, si_addr=0x18} ---
+++ killed by SIGSEGV +++
Segmentation fault


I didn't see anything really bad until SIGSEGV killed the program. A quick googling led me to this stackoverflow post which suggested using gdb...

$ gdb LeadwerksUpdater
Reading symbols from LeadwerksUpdater...(no debugging symbols found)...done.
(gdb) run
Starting program: /home/kobnar/Applications/leadwerks/LeadwerksUpdater
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
Program received signal SIGSEGV, Segmentation fault.
0xf7655d05 in __longjmp_chk () from /lib32/libc.so.6


For good measure, here's a screenshot of the blank window (held open by gdb)...



Checked into what package owns /lib32/libc.so.6...

# equery belongs /lib32/libc.so.6
* Searching for /lib32/libc.so.6 ...
sys-libs/glibc-2.19-r1 (/lib32/libc.so.6 -> libc-2.19.so)
sys-libs/glibc-2.19-r1 (/lib32/libc-2.19.so)


Since I can't downgrade glibc, my only option was to go searching for the Ubuntu package with the same file which lead me to libc6-i386_2.19-0ubuntu6_amd64.deb. Using dpkg, I extracted the packaged into a folder named badlibs/ (following the process described here). I found libc.so.6 in badlibs/lib32 linked to a new libc-2.19.so...


$ ls -l badlibs/lib32/libc.so.6
lrwxrwxrwx 1 kobnar kobnar 12 Apr 12 03:39 badlibs/lib32/libc.so.6 -> libc-2.19.so


Once again, I fired up gdb to see if using a new library would change anything...

$ gdb LeadwerksUpdater
Reading symbols from LeadwerksUpdater...(no debugging symbols found)...done.
(gdb) set env LD_LIBRARY_PATH /home/kobnar/Applications/leadwerks/badlibs/lib32
(gdb) run
Starting program: /home/kobnar/Applications/leadwerks/LeadwerksUpdater
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
Program received signal SIGSEGV, Segmentation fault.
0xf7647cb5 in __longjmp_chk () from /home/kobnar/Applications/leadwerks/badlibs/lib32/libc.so.6


Since neither library changed anything, I figure I'm going to start googling around for __longjmp_chk and find out what it does, since that's where the fault happens.


(PS: This is my first attempt at seriously debugging something, so any help/advice would be appreciated)

Link to post

Sorry I haven't posted until now. Life beckoned...


$ emerge -pv nvidia-drivers

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] x11-drivers/nvidia-drivers-340.24  USE="X acpi multilib tools -pax_kernel -uvm" 0 kB


# lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation GK106 [GeForce GTX 660] (rev a1)


$ emerge --info
Portage 2.2.10 (default/linux/amd64/13.0/desktop, gcc-4.8.3, glibc-2.19-r1, 3.15.5-gentoo x86_64)
System uname: Linux-3.15.5-gentoo-x86_64-Intel-R-_Core-TM-_i7-3770K_CPU_@_3.50GHz-with-gentoo-2.2
KiB Mem:    16389644 total,    593620 free
KiB Swap:   33562608 total,  33562356 free
Timestamp of tree: Mon, 21 Jul 2014 19:15:01 +0000
ld GNU ld (GNU Binutils) 2.24
app-shells/bash:		  4.2_p47
dev-java/java-config:	 2.2.0
dev-lang/python:		  2.7.7, 3.4.1
dev-util/pkgconfig:	   0.28-r1
sys-apps/baselayout:	  2.2
sys-apps/openrc:		  0.12.4
sys-apps/sandbox:		 2.6-r1
sys-devel/autoconf:	   2.69
sys-devel/automake:	   1.11.6, 1.14.1
sys-devel/binutils:	   2.24-r3
sys-devel/gcc:		    4.8.3
sys-devel/gcc-config:	 1.8
sys-devel/libtool:	    2.4.2-r1
sys-devel/make:		   4.0-r1
sys-kernel/linux-headers: 3.15 (virtual/os-headers)
sys-libs/glibc:		   2.19-r1
Repositories: gentoo sublime-text gamerlay sabayon dotnet java ezod
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
EMERGE_DEFAULT_OPTS="--jobs=8 --load-average=8"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="rsync://mirror.mcs.anl.gov/gentoo/ http://mirror.mcs.anl.gov/pub/gentoo/ ftp://mirror.mcs.anl.gov/pub/gentoo/ ftp://mirror.datapipe.net/gentoo http://mirror.datapipe.net/gentoo http://gentoo.mirrors.easynews.com/linux/gentoo/ http://www.gtlib.gatech.edu/pub/gentoo ftp://ftp.gtlib.gatech.edu/pub/gentoo rsync://rsync.gtlib.gatech.edu/gentoo http://gentoo.mirrors.hoobly.com/ ftp://ftp.ussg.iu.edu/pub/linux/gentoo ftp://lug.mtu.edu/gentoo/ http://lug.mtu.edu/gentoo/ ftp://gentoo.netnitco.net/pub/mirrors/gentoo/source/ http://gentoo.netnitco.net http://gentoo.osuosl.org/ ftp://gentoo.mirrors.pair.com/ http://gentoo.mirrors.pair.com/ rsync://mirrors.rit.edu/gentoo/ ftp://mirrors.rit.edu/gentoo/ http://mirrors.rit.edu/gentoo/ ftp://mirror.iawnet.sandia.gov/pub/gentoo/ http://mirror.iawnet.sandia.gov/gentoo/ ftp://gentoo.llarian.net/pub/gentoo http://gentoo.llarian.net/ http://gentoo.mirrors.tds.net/gentoo http://ftp.ucsb.edu/pub/mirrors/linux/gentoo/ ftp://ftp.ucsb.edu/pub/mirrors/linux/gentoo/ ftp://ftp.lug.udel.edu/pub/gentoo/ http://mirror.lug.udel.edu/pub/gentoo/ http://gentoo.cites.uiuc.edu/pub/gentoo/ ftp://gentoo.cites.uiuc.edu/pub/gentoo/ http://gentoo.cs.uni.edu/ rsync://gentoo.cs.uni.edu/gentoo-distfiles http://mirror.usu.edu/mirrors/gentoo/ ftp://ftp.wallawalla.edu/pub/mirrors/ftp.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9 -l8"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/sublime-text /var/lib/layman/gamerlay /var/lib/layman/sabayon /var/lib/layman/dotnet /var/lib/layman/java /var/lib/layman/ezod"
USE="X a52 aac acl acpi alsa amd64 berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm gtk gtk2 gtk3 iconv introspection ipv6 jpeg lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg multilib ncurses networkmanager nls nptl ogg opengl openmp pam pango pcre pdf png policykit polkit ppds pulseaudio qt3support qt4 readline samba sdl session spell sse sse2 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xcb xml xv xvid zlib" ABI_X86="64 32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="emu efi-32 efi-64 pc" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

Link to post

Not that it will help much, but I have been picking at this problem when I have free time to no avail. I tried downloading all of the dependencies into their own path (similar to the workaround for this other issue) and running the program with a custom "LD_LIBRARY_PATH" but it still crashed.


Here's the gdb back-trace:

$ LD_LIBRARY_PATH=badlibs/lib/i386-linux-gnu/ gdb LeadwerksUpdater
GNU gdb (Gentoo 7.7.1 p1) 7.7.1
Copyright (C) 2014 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
Find the GDB manual and other documentation resources online at:
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from LeadwerksUpdater...(no debugging symbols found)...done.
(gdb) run
Starting program: /home/kobnar/Applications/leadwerks/LeadwerksUpdater
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
Program received signal SIGSEGV, Segmentation fault.
0xf766e175 in __longjmp_chk () from badlibs/lib/i386-linux-gnu/libc.so.6
(gdb) backtrace
#0  0xf766e175 in __longjmp_chk () from badlibs/lib/i386-linux-gnu/libc.so.6
#1  0xedc82ff4 in ?? () from /usr/lib32/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-png.so
#2  0x080599fe in png_error ()
#3  0x0805643c in png_create_read_struct_2 ()
#4  0xedc83dcb in ?? () from /usr/lib32/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-png.so
#5  0xf7558a7d in ?? () from /usr/lib32/libgdk_pixbuf-2.0.so.0
#6  0xf7558bbc in gdk_pixbuf_new_from_file () from /usr/lib32/libgdk_pixbuf-2.0.so.0
#7  0xf451671c in ?? () from /usr/lib32/gtk-2.0/2.10.0/engines/libpixmap.so
#8  0xf7d6fc21 in g_cache_insert () from badlibs/lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xf45176f0 in ?? () from /usr/lib32/gtk-2.0/2.10.0/engines/libpixmap.so
#10 0xf4517781 in ?? () from /usr/lib32/gtk-2.0/2.10.0/engines/libpixmap.so
#11 0xf45140c0 in ?? () from /usr/lib32/gtk-2.0/2.10.0/engines/libpixmap.so
#12 0xf4514c3b in ?? () from /usr/lib32/gtk-2.0/2.10.0/engines/libpixmap.so
#13 0xf7aa9617 in gtk_paint_check () from /usr/lib32/libgtk-x11-2.0.so.0
#14 0xf797adf2 in ?? () from /usr/lib32/libgtk-x11-2.0.so.0
#15 0xf797aaf3 in ?? () from /usr/lib32/libgtk-x11-2.0.so.0
#16 0xf7a1a37e in ?? () from /usr/lib32/libgtk-x11-2.0.so.0
#17 0xf77ad584 in ?? () from /usr/lib32/libgobject-2.0.so.0
#18 0xf77ae9d2 in g_closure_invoke () from /usr/lib32/libgobject-2.0.so.0
#19 0xf77c0c60 in ?? () from /usr/lib32/libgobject-2.0.so.0
#20 0xf77c866f in g_signal_emit_valist () from /usr/lib32/libgobject-2.0.so.0
#21 0xf77c8bd3 in g_signal_emit () from /usr/lib32/libgobject-2.0.so.0
#22 0xf7b45f13 in ?? () from /usr/lib32/libgtk-x11-2.0.so.0
#23 0xf79946c8 in gtk_container_propagate_expose () from /usr/lib32/libgtk-x11-2.0.so.0
#24 0xf79946f0 in ?? () from /usr/lib32/libgtk-x11-2.0.so.0
#25 0xf7a0fb70 in ?? () from /usr/lib32/libgtk-x11-2.0.so.0
#26 0xf7992f0f in gtk_container_forall () from /usr/lib32/libgtk-x11-2.0.so.0
#27 0xf7993112 in ?? () from /usr/lib32/libgtk-x11-2.0.so.0
#28 0xf7a1051b in ?? () from /usr/lib32/libgtk-x11-2.0.so.0
#29 0xf7a1a37e in ?? () from /usr/lib32/libgtk-x11-2.0.so.0
#30 0xf77ad584 in ?? () from /usr/lib32/libgobject-2.0.so.0
#31 0xf77aea5e in g_closure_invoke () from /usr/lib32/libgobject-2.0.so.0
#32 0xf77c0c60 in ?? () from /usr/lib32/libgobject-2.0.so.0
#33 0xf77c866f in g_signal_emit_valist () from /usr/lib32/libgobject-2.0.so.0
#34 0xf77c8bd3 in g_signal_emit () from /usr/lib32/libgobject-2.0.so.0
#35 0xf7b45f13 in ?? () from /usr/lib32/libgtk-x11-2.0.so.0
#36 0xf7a18de7 in gtk_main_do_event () from /usr/lib32/libgtk-x11-2.0.so.0
#37 0xf787a8e0 in ?? () from /usr/lib32/libgdk-x11-2.0.so.0
#38 0xf787a933 in ?? () from /usr/lib32/libgdk-x11-2.0.so.0
#39 0xf787a933 in ?? () from /usr/lib32/libgdk-x11-2.0.so.0
#40 0xf78ab253 in ?? () from /usr/lib32/libgdk-x11-2.0.so.0
#41 0xf7877168 in ?? () from /usr/lib32/libgdk-x11-2.0.so.0
#42 0xf7877c88 in gdk_window_process_updates () from /usr/lib32/libgdk-x11-2.0.so.0
#43 0xf7b565cb in ?? () from /usr/lib32/libgtk-x11-2.0.so.0
#44 0xf77b0693 in g_cclosure_marshal_VOID__VOID () from /usr/lib32/libgobject-2.0.so.0
#45 0xf77ad584 in ?? () from /usr/lib32/libgobject-2.0.so.0
#46 0xf77aea5e in g_closure_invoke () from /usr/lib32/libgobject-2.0.so.0
#47 0xf77c0c60 in ?? () from /usr/lib32/libgobject-2.0.so.0
#48 0xf77c8943 in g_signal_emit_valist () from /usr/lib32/libgobject-2.0.so.0
#49 0xf77c8bd3 in g_signal_emit () from /usr/lib32/libgobject-2.0.so.0
#50 0xf7992aca in gtk_container_check_resize () from /usr/lib32/libgtk-x11-2.0.so.0
#51 0xf7992d40 in ?? () from /usr/lib32/libgtk-x11-2.0.so.0
#52 0xf7854788 in ?? () from /usr/lib32/libgdk-x11-2.0.so.0
#53 0xf7d9cc50 in ?? () from badlibs/lib/i386-linux-gnu/libglib-2.0.so.0
#54 0xf7da00a7 in g_main_context_dispatch () from badlibs/lib/i386-linux-gnu/libglib-2.0.so.0
#55 0xf7da0468 in ?? () from badlibs/lib/i386-linux-gnu/libglib-2.0.so.0
#56 0xf7da0528 in g_main_context_iteration () from badlibs/lib/i386-linux-gnu/libglib-2.0.so.0
#57 0xf7a17bf1 in gtk_main_iteration_do () from /usr/lib32/libgtk-x11-2.0.so.0
#58 0x08082d80 in ?? ()
#59 0x080a8806 in ?? ()
#60 0x08099a11 in ?? ()
---Type <return> to continue, or q <return> to quit---quit
(gdb) quit
A debugging session is active.
Inferior 1 [process 26801] will be killed.
Quit anyway? (y or n) y


I've tried downgrading gtk-pixbuf, gtk-engines, glib, gtk+ and libpng to various other versions. I still get a segmentation fault 100% of the time I try to run LeadwerksUpdater.

Link to post
  • 3 months later...

I now have both Ubuntu and Gentoo (replaced Arch) also over here.

I got the Lua (3.3) editor working via Steam, but with bad interface.

and looks like I have the same issue Kobnar showed with with fault.


Did anyone of you managed to run the C++ version on Gnetoo? if yes post the package list used to emerge.

What's nice about Gentoo is that you can create overlays for portage,

we could me a Leadwerks overlay if some package setting would work.


What would be even nicer is a 64-bit version of the editor, won't need all this 32-bit **** in my system.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Facebook Twitter Youtube Github Steam
  • Create New...