Jump to content
JoshMK

Official Leadwerks Exporter for Blender

Recommended Posts

Below you can find the official Leadwerks exporter for Blender.

leadwerks-blender-exporter.zip

Repo:

https://github.com/alrusdi/leadwerks-blender-exporter

Installation

  1. Put the io_scene_leadwerks into your Blender addons directory. Refer to the official blender documentation to find addons directory
  2. Press Ctrl+Alt+U
  3. Select Addons
  4. Select Category = Import Export
  5. Mark Leadwerks

post-1-0-78322800-1405700318.png

 

Thanks to alrusdi and Roland for the exporter and installation instructions.

Share this post


Link to post

I'm getting "couldn't find any exportable objects" when I tell it to only export what's selected. Is that an expected behaviour?

Well... Did you selected something on scene before export? Please provide your .blend file if so.

Share this post


Link to post

Hi, I downloaded the program and tried to import it. I followed the instructions to the letter but the add-on doesn't show up in Blender. I'm not sure what to do.

Share this post


Link to post

Just my recommendation for creating quick materials with Blender for the Leadwerks engine. Making th materials quickly is easy in Blender. Using them in Leadwerks is also very easy. The bottleneck lies in the exporter and here I reason why in the video. I also encourage anyone to try my technique for crating materials - good looking materials - quickly instead of using images online. With blender, you can create fast seamless textures.

 

http://youtu.be/C_gc4mqpUWk

Share this post


Link to post

I can export objects without issues though I am having problems with animations.

 

Does the exporter support NLA tracks?

 

So far I can only get it to export a single animation even if I specify all actions.

Share this post


Link to post

I too am having problems with animations - In fact this was the reason I am a Leadwerks customer, the promise of easy blender->game engine workflow.

 

I have a model that is set up with bones and vertex groups, and animated using IK with bones in the skeleton as targets.

 

The exporter pulls out the deformed mesh ok (according to whatever frame was set when invoking the exporter) but the skeleton in Leadwerks is messed up, and no animation on the mesh is evident.

 

Exporting to FBX yields a different result - a correctly animated skeleton in Leadwerks model viewer, but no movement in the mesh itself.

 

Are there some examples of blender character rigs that do export correctly into Leadwerks so I can emulate their construction?

 

Are there limitations (like with OGRE's hardware skinning) around how many bones a vertex may be affected by?

Share this post


Link to post

Hi, further to my previous post, I have a test .blend, a very simple cube mesh, with 2 bones, an IK target bone and a single action.

 

http://marchingcubes.com/leadwerks_test.blend

 

and the result:

 

http://marchingcubes.com/leadwerks_test.mdl

 

When i export this to leadwerks using the leadwerks blender exporter, load it in the model viewer, and assign a material with animation support e.g. the crawler material, the animation does play, but I get the mesh flickering in and out of existence at various frames.

 

I am on ubuntu 14.04, using leadwerks 3.3 from steam, blender 2.72 and the latest blender exporter from this site.

 

Hopefully you can reproduce and/or suggest a fix for me, I would really like to get this resolved as a solid pipeline for doing armature-driven animation from blender is essential to my work.

Share this post


Link to post

Sorry for the forum spam, but additional info:

 

The animations that flicker and appear broken in the model viewer would actually seem to work OK in the game world.

 

Is this 'animated meshes flicker and appear broken' a known bug in the model viewer on Linux? If so, it would be good to get a fix for this, as every tutorial and document around animated meshes relies heavily on usage of the model viewer.

Share this post


Link to post

And more.. now that it seems from reading other bug reports that the model viewer is indeed just broken with animated meshes on Linux, ignoring that, and loading the exported objects into the engine seems to mostly work (i have an animated mesh in my game, w00t!), but it seems that multiple actions are not exported correctly - the model editor shows there are multiple animations in the model with names corresponding to the actions set up in blender, but using the SingleAnimation.lua script to play them back just plays the same animation, regardless of the index used.

 

As far as I can see, it looks like when the leadwerks exporter is baking out its animations it is not actually switching the action on the bound skeleton (the same actions show up on the object as well as the armature, maybe this is where the problem is?), resulting in a number of actions exported, but all with the same data as whatever action was currently set to active on the skeleton at the time of export.

 

I have attached a second .blend file and exported .mdl with a cube containing 2 actions (one called 'test' and one called 'second_action') with keyframes on the bones of the skeleton, however examination of the .mdl should show that 'second_action' is actually a clone of 'test' after export.

 

 

http://marchingcubes.com/leadwerks_test2.blend

 

 

http://marchingcubes.com/leadwerks_test2.mdl

 

It is also possible I am setting up my models and rigs wrong for optimal leadwerks use - perhaps there is something I can do to avoid this issue?

Share this post


Link to post

Hopefully this isn't cluttering the forum too much, but I have now got multiple actions from my blender project into my leadwerks model using the blender exporter.

 

It is necessary to have the armature selected in the blender GUI when invoking the export script, not the mesh it is affecting - previously I had my model selected in Object Mode, and this resulted in the first action being duplicated for all actions - if multiple actions are to be successfully exported, the armature should be selected, in Pose Mode, before invoking the export script.

 

I hope this helps others who are having difficulty getting their animations into Leadwerks.

Share this post


Link to post

Have you tried the FBX export from Blender?

I do not understand what is difference between exporting to fbx format with plain blender (no plugin) and using "Leadwerks Exporter for Blender" plugin. Sorry if answer is obvious (just started to learn Leadwerks).

Share this post


Link to post

I can't get this to show up in addons for some reason. I unzipped the file into a folder. Under addons in blender i selected "install from file" then i selected folder io_scene_leadwerks folder, and clicked install from file and window swaps back to addons list with no changes updated. Can someone help me please?

Share this post


Link to post

Can anyone explain how to get a texture out with cycles renderer?

 

I can get the png files generating if I use Blenders old Render but when I try to use cycles the image file doesn't appear but the mat file does (with no image file reference). I don't know if it is because I don't know how to do it, or if you have to use the old render materials? Materials look fine with cycles in the viewport (as far as I can tell).

 

Can anyone explain using export with cycles materials?

 

Thanks,

 

Michael

 

 

Share this post


Link to post

HI. I have a problem with the exporter, it doesn't export parameters of child objects properly.

My object looks looks like this in Blender:

 

blender.png

 

And this is how it looks like in Leadwerks:

leadwerks.png

 

As you can see the blue thing which is a child object, is not right. It position and angle is wrong. Tried the fbx exporter of Blender but I can't import it. I get "failed to load object" error message.

 

Using Blender 2.71

 

Thanks.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...