Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Official Leadwerks Exporter for Blender


Recommended Posts

  • 6 months later...
  • 2 weeks later...

Hello,

 

Bugreport:

1. the Error "Couldn't find exportable Objects" comes if the selected Object has a Parent.

Workaround: Unparent the object you want to export.

 

2. it would be awesome if the exporter would remember the checkboxes I checked (export only selected models) even when the last export went wrong... (the "export only selected" should be default in my opinion..)

 

anyway a good exporter - keep updating!

 

yours

Max Aigner

Link to post
Share on other sites
  • 2 weeks later...

Hi, further to my previous post, I have a test .blend, a very simple cube mesh, with 2 bones, an IK target bone and a single action.

 

http://marchingcubes.com/leadwerks_test.blend

 

and the result:

 

http://marchingcubes.com/leadwerks_test.mdl

 

When i export this to leadwerks using the leadwerks blender exporter, load it in the model viewer, and assign a material with animation support e.g. the crawler material, the animation does play, but I get the mesh flickering in and out of existence at various frames.

 

I am on ubuntu 14.04, using leadwerks 3.3 from steam, blender 2.72 and the latest blender exporter from this site.

 

Hopefully you can reproduce and/or suggest a fix for me, I would really like to get this resolved as a solid pipeline for doing armature-driven animation from blender is essential to my work.

 

I Also have this issue.

I run Blender and Leadwerks on Linux.

I have tried to do the Blender Work and exporting in Windows and importing in Leadwerks on Linux, but with the same result. I havent tried to Import on Windows Leadwerks since i dont have a Windows machine with OpenGL 4 support :(

I am running my Windows build environment in Virtualbox. So i can run Blender and build the solution in Visual studio.

Link to post
Share on other sites

Its not just the model viewer.

The model from the Crawler works fine in the Leadwerks model viewer and the model imported from blender does not work in game.

 

If i can't do animations with Blender and import to Leadwerks. Does any one know another solution that can be used?

This is really a showstopper for me right now sad.png

Link to post
Share on other sites
  • 2 years later...
  • 6 months later...
  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Facebook Twitter Youtube Github Steam
×
×
  • Create New...