Jump to content
Guppy

[Lua] dynamic libraries not enabled

Recommended Posts

I get "Lua Error: error loading module 'plugin/libLua-test' from file './plugin/libLua-test.so':|dynamic libraries not enabled; check your Lua installation" When I try to load my own library.

 

This thread http://www.leadwerks.com/werkspace/topic/10566-require/page__hl__require suggests that turning off sandbox will do the trick - I've tried it both in the LE editor and in c++ neither makes any difference.

 

Since he made it work I'm thinking this could be the linux version having different lua permissions?

 

Or is removing the sandbox check mark and doing

Interpreter::sandboxmode=false;

in App::Start() before loading the map not enough to turn off sandbox?

Share this post


Link to post

Anyone with linux can download the very exciting plugin here;

 

https://drive.google.com/file/d/0B7B0hlkpWcYWVmhkOEtaTFJ5bzA/edit?usp=sharing

 

I put it in a subfolder named "plugin" but you can stick it anywhere - just adjust the path acordingly

 

require("plugin/libLua-test")

 

it exposes the functions "sayHi" and addTwo(....);

 

System:Print(test.sayHi())

System:Print(test.addTwo(1,2,3,4))

 

_

 

This

http://lua-users.org/lists/lua-l/2014-05/msg00267.html

 

Seems to suggest that there is a missing define in the linux build

Share this post


Link to post

Did you disable the sandboxing option in the editor options?

 

That was the sandbox checkmark I was refering to yes

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...