Jump to content
neseir

Strange position on new objects

Recommended Posts

Hi

 

Did a new installation of Steam and Leadwerks on a Ubuntu 14.04 64 bit installation. Got a problem with the new objects I create are in their properties located at very high coordinates (like 0.0, 100000000.0, 0.0). Visually they are properly positioned since they are where I put them but as soon as I changes something in their properties, they dissapear from the screen (probably they are positioned to the coordinates given in their properties setting).

 

Have attached a screenshot where I have just added a Box, and switched to the box's properties in the scene. Have not experienced this on the Windows edition.

 

LW_bug.png

 

BR

Eirik

Share this post


Link to post

This might help :

 

Tools->Options->Viewport->Grid Units

 

Change it to Meters.

Share this post


Link to post

Hi Shadmar

 

Tested with first setting the Grid Units to meters but when adding the second box it still positions it way of in the properties.

 

LW_bug_2.png

 

//Eirik

Share this post


Link to post

Thanks DerRidda

 

Tested changing the input -format etc but it did not solve the positionining (did not log out/in again) but I'm convinced You are right (I'm using norwegian keyboard and number-/date-formatting with english (US) language).

 

When I switch of the "snap to grid", all objects I move using the spin edits does not recognize any decimals, just the rounded value.

 

Moving a box will never be located at other than rounded coordinates. Some of them are very far of the scene I started with (even if they visually are shown in the viewport).

 

//Eirik

Share this post


Link to post

Just to confirm the configuration I set my profile to use English(us) and US number-formatting, logged off and started a new session. Everything in Leadwerks regarding the positioning of the objects works perfect now. The only problem now is that I have not used a US layout on the keyboard since I used my Amiga 500 and later Amiga 2000 ..... unsure.png

 

//Eirik

Share this post


Link to post

Don't go overkill, just launch Leadwerks with "LC_ALL=C LANG=en_US.UTF-8 %command%" in the Steam launch options/add "LC_ALL=C LANG=en_US.UTF-8" to your launch script for the stand alone version.

Share this post


Link to post

Thanks for the information smile.png

 

I will add this to the launcher tomorrow (it's a bit late here).

 

//Eirik

Share this post


Link to post

OK, could not go to sleep without testing this .....

 

Works perfect !! Had to search a bit for the optionspanel but once I found it and added the suggested settings, all problems with the formatting gone.

 

Thanks a lot !

 

//Eirik

Share this post


Link to post
Guest
This topic is now closed to further replies.
×
×
  • Create New...