Jump to content
Evil Resident

Physic box vs polymesh problem

Recommended Posts

Good day everyone

 

Ok, I have this problem... I'm trying to animate a elevator using the sliding door script.

When I set the physic shap to box it works, the elevator goes up, but I can't go in (not surprising). When I set my physic shape to polymesh or using my shape file, the elevator dosen't do anything. Why is that ?

Any suggestions?

post-12907-0-25215000-1413731503_thumb.jpg

Share this post


Link to post

The easiest way is to place some brushes in the scene to make the shape you want, then parent them to the elevator and check the "Shape Hint" box on each brush, then hide them. The engine will use the brushes to build a physics shape for you when the map is loaded. You might want to save that object as a prefab so you can just reuse the same physics.

Share this post


Link to post

It might also be worth to mention that what you experience is 100% expected behavior for polymesh physics shapes. They are for static geometry only.

Share this post


Link to post

It might also be worth to mention that what you experience is 100% expected behavior for polymesh physics shapes. They are for static geometry only.

 

I will keep that in mind Thanks

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...