Jump to content
klepto2

Terrain Editor keeps being active while doing other stuff

Recommended Posts

Hi,

 

if you sculpt or paint a terrain and then move/create/ rotate an entity in the Perspective-window via the gizmos, the terrain edit mode is still active and you edit the terrain without wanting it. Also happens if you drag and drop entities from the asset window.

 

klepto2

Share this post


Link to post

Has that not always been the case? I always assumed when you were done with the terrain you would have to select the object selection button to get out of terrain editing? Did this used to automatically switch to object editing previously?

post-14-0-30612900-1413917106.jpg

Share this post


Link to post

As Macklebee stated, it has always been this way. I found out when I was building a map with a bridge going across a canyon. While trying to place the bridge the canyon kept growing.

Share this post


Link to post

Just because it has always been this way doens't mean it is not a bug.

In my opinion rotating/moving an object should never result in doing something else then rotating/moving an object.

  • Upvote 3

Share this post


Link to post

This has gotten me a few times as well. I feel like if you select an entity in anyway, scene tab or perspective view, then it should take you out of terrain edit mode. If I'm in terrain edit mode and select an entity I expect to be able to move/rotate that entity, but that's not the case. I think that's what these guys are saying.

  • Upvote 1

Share this post


Link to post

You can't select an object in the perspective view when the terrain editor is active.

Share this post


Link to post

From my memory I can in the scene tab. Can you select in the 2D views? Not at home atm. Either way, any selection of an object should put the editor in entity mode vs terrain mode from my perspective.

Share this post


Link to post

In LE2, you got around this by disabling the object selection/3d gizmos whenever terrain editing was enabled and to get to new assets you had to press the 'Objects' button. In LE3, you can swap tabs now from terrain to assets/objects/scene without having to select the 'Select Object' button. Perhaps a change is needed to only enable terrain editing features when the terrain tab is active and to disable all object selection/3d gizmos.

Share this post


Link to post

Ah, okay. I fixed it so selecting an object in the scene browser switches you back to object selection mode.

 

It's a little odd of a design problem. Switching tabs, in my view, should not change control modes. That's not a standard interface behavior.

 

One thing I find a little strange about Leadwerks 3 is the amount of stuff that's packed in the main window. For example, object properties are typically a dialog box the user opens, with "OK", "Apply", and "Cancel" buttons. But having the properties box react real-time in the main window makes editing faster and it's more convenient. This was a very common request in Leadwerks 2.

 

The terrain editor also used to be a separate window, now it's packed into a tabbed panel.

Share this post


Link to post

Ah, okay. I fixed it so selecting an object in the scene browser switches you back to object selection mode.

...

It's a little odd of a design problem. Switching tabs, in my view, should not change control modes. That's not a standard interface behavior.

 

Ok, but what about if you go to the Assets tab? Dragging and dropping an asset still has the terrain editing active. As far as standard interface behavior, the interaction is the same for the user. LE2, I had to press a button to switch from the terrain panel/window to the assets panel/window. In LE3, I just have to press a tab to do the same. I fail to see the difference when both will drive the same event based on one click... but eh... not a big deal to me really because I've already conditioned myself to take 1 second and press the 'Select Object' button when I am done editing a terrain.

Share this post


Link to post

The current beta build will switch editing mode based on selected tabs. It's a little odd, because you have the button to do it, and then the tabs as well automatically switch the buttons. But I think the user is most likely to not even notice it, because it's just working as they expect it to, without even thinking about it. Let me know what you think.

  • Upvote 1

Share this post


Link to post

For me the fixed behaviour works perfectly.

agreed - terrain editing only when terrain tab is active seems to make the most sense.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...