Jump to content
lxFirebal69xl

Door problem.

Recommended Posts

So I was just randomly working on my game when I came across this weird little problem. I don't know what gives since I've done the EXACT same "puzzle" before but now it's has this weird glitch on it.

 

The issue is that the player is able to use a door that's only openable via a button. and causes this weird behaviour, while in the pre-alpha level, I did the exact same thing TWICE, same scripts and everything. I've already checked the FPSPlayer, but it can't be that since I can play the other levels fine with it.

 

 

Here are the doors that work without problems.

post-13811-0-42369600-1426376809_thumb.png

 

 

And the doors that have problems...

post-13811-0-94102600-1426376833_thumb.png

 

 

 

Any ideas as to what could be causing this?

Share this post


Link to post

The pictures posted don't match what the video shows is weird. The video shows the hand icon on the "door" as well as the controlpanel. The hand icon is enabled by the "Manual activate" being true which in this case I would assume you wouldn't want on the doors. Is the video from playing via the editor or from a published/exported game? Asking because it looks like the map in the editor is not what is being shown in the video - unless you have changed the default scripts. Also, it would probably be helpful to see the flowgraph logic between the controlpanel and the door.

Share this post


Link to post

The pictures posted don't match what the video shows is weird. The video shows the hand icon on the "door" as well as the controlpanel. The hand icon is enabled by the "Manual activate" being true which in this case I would assume you wouldn't want on the doors. Is the video from playing via the editor or from a published/exported game? Asking because it looks like the map in the editor is not what is being shown in the video - unless you have changed the default scripts. Also, it would probably be helpful to see the flowgraph logic between the controlpanel and the door.

 

The video is the same map from the second picture. I assure you, but it is being played in the editor. And I have not changed the default scripts in any way.

Share this post


Link to post

The only thing i could suggest is to remove the doors and place it back it the scene between saves. Then try re-attaching the script to make sure the 'manual activate' was not enabled on the door.

Share this post


Link to post

Maybe isolate the problem door into a blank map and post it up for people to check. Check that your physics/collision are right too, my doors act possesed if I forget to switch them from prop to scene collision.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...