Jump to content
josk

Lockdown

Recommended Posts

Version 1.32 09/06/15

I was assigned to Research Station Alpha a few months ago. Built into a hollowed out asteroid which orbits a star in a long abandoned system light years from Earth.

Why i got stationed here when my career is almost at an end is the question I have asked myself many times each day I have been here.

 

I go about my dutys even though the jobs are minimal and just more of the same old.

 

All I remember this day is that I went into a storeroom and then the room shook as the lights went out, I must have hit my head because now I have the most incredible headache which in this case is not induced by to much alcohol or to much caffiene.

The emergency lights are on so the generators must be out, thats a simpe job that I best do before the major gets on the comms.

Theres an intercom at the bottom of the stairs near the canteen, I might get some information there.

Also the canteen is where I left my access card and maybe some Tablets for my head.

 

I can get into the equipment locker then because I have a bad feeling I will need them.

 

The game.

Discover the secret of Station Alpha and survive whatever has happened. Use your skills and equipment wisely to solve any puzzles.

Find other station personnel who might aid you.

 

Press C to view controls

W,A,S,D movement

Q,E turning

F for interaction

Click inventory items to use

Click coloured blocks then move them with your arrow keys.

1,2,3 to change resolution.

 

This is a rough alpha demo of the first level. Read more in this thread. about what got left out and things I know that need doing. The story is rough but you get the gist. Only one starting professon, hope you like it.

Video and picture will be updated asap.

 

Feedback and suggestions appreciated and gladly accepted.


View full game

Share this post


Link to post
Share on other sites

Some first quick test :

- starting the game i have some windows that displays a white screen instead of a loading screen

- the the resolution changes to a lower window size when the game starts

-Having to clikc on the white hand to pick up objects is not natural, a raycast pick should display a Get hand symbol instead and clikcing would pick teh object

- We should be able o pick objects when on screen without needing to be right in front on them

- In the demo the fire particle don't show

- beeing in front of the fire panel and if i click on the extinctor on the inventory the game crashes Radeon HD 7600)

-strafing left and right , some times i couldn't position right in front of the main door , it was frustrating (perhaps needs to sync key detection and number of strafes ?)

 

It's very promising , the textures are great.

Share this post


Link to post
Share on other sites

Just had a quick go. Biggest issue I had is the last one yougroove mentioned. It doesn't seem to be a standard movement grid or something, so when I went close to wall strafing lined up different to when far away from wall.

Share this post


Link to post
Share on other sites

The grid felt fine to me, but I have never played this kind of game. One thing that threw me off is you've got the hand, the crosshair, and the mouse cursor all at once when you can pick something up.

Share this post


Link to post
Share on other sites

Hi,

 

This worked fine until I tried to put out the fire. Clicked on the fire extinguisher in my inventory, the fire went out, a 'whoosh' sfx played and it the crashed to desktop. No error message or any kind of dump feedback so I'm afraid I can't give any further info, apologies.

 

I'll try the next build you have as I do like these kind of games ;)

 

- Matt.

Share this post


Link to post
Share on other sites

Nice idea, but the grid approach was really hard to get used to. And then it would continuously get out of alignment. Right at the end I was just battling the keyboard just to get through a door.

Share this post


Link to post
Share on other sites

Still at work at the moment but thanks for all the feedback and will take a good luck tonight.

 

Interested to know that if it crash's are you using a AMD Radeon card as at the moment no Nvidia cards have crashed.

Share this post


Link to post
Share on other sites

Right made a few changes.

 

No crosshair.

Replaced mouse curser with a green hand.

When you are near a usable object a white hand appears above it. Press LMB or F to use.

( Thinking of moving the green hand over the white when it appears.)

 

In the demo the fire particle don't show

So you dont see the flames just the flickering light?

 

Fullscreen and resoultion sorted, no loading screen as yet just a black screen.

 

Movement, changed it a bit.

There is now player location in the top left. x and z should always be a round odd number.

Let me know if the changes work.

The movement is something I was going to overhaul when I started the second level and then replace into the first level.

 

Regarding the crashing, I was hiding the flames which uses shadmars fire shader. Not sure if this caused it.

I am now just moving its position to see if the crash stops.

 

It's very promising, the textures are great.

Thanks, textures are all purchased from seperate places.

 

Thanks for trying and let me know if the changes work better.

Still more to do.

Share this post


Link to post
Share on other sites

Will the game have lot of fights like Grimrock 2 ?

The idea to let down square based moves, to full FPS like System Shock 2 could be a good option to consider also ?

Or is square based making things more easy to manage ?

Share this post


Link to post
Share on other sites

Don't mention System Shock.

 

With Lockdown I have gone from wanting to do a Grimrock type to System Shock type hundreds of times. blink.png

 

Fights would be like Grimrock.

Share this post


Link to post
Share on other sites

Running on Linux....

 

I don't see the fire either.

Also... I can pick up items with f, and see them placed in the inventory. However I can't use them. Clicking on both the flashlight and the fire extinguisher do nothing. So I'm stuck in the first room...

Share this post


Link to post
Share on other sites

Thanks for testing, think I might have sorted the missing flames. A few people have mentioned that.

 

Looking into the inventory problem.

 

Nice to see it running in part on Linux.

Share this post


Link to post
Share on other sites
v1.21 has fixed the crash whilst putting out the fire smile.png

 

Excellent, should hopefully have solved that for everyone.

 

I'll have a proper play later on a give any additional feedback.

 

I may have to change one or two more bits as it may crash again later on. Will take a look when I get home and upload a new version if necessary.

If anyone spots a new crash let me know.

Share this post


Link to post
Share on other sites

Ok version 1.22 uploaded.

V 1.21 fixed the game crashing when you put the fire out (if not let me know).

This small update should stop any more crashs due to similier situations.

 

Also this might fix it for the people who couldn't see the flames.

 

thanks.

Share this post


Link to post
Share on other sites

Thanks for that, I think I have that sorted now, it will be in the next update.

Though I am looking at particles for the fire now.

 

I'm away working all weekend but I will be working on the inventory next week.

Share this post


Link to post
Share on other sites

A new update is available which should hopefully fix the few problems people might have been having.

 

As always feedback is welcome.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...