Jump to content
pracedru

Blender animation import in Leadwerks

Recommended Posts

I have an Issue when I import Models from Blender that are animated with bones and armatures.

I have the Leadwerks export plugin installed in Blender but you can also export with FBX.

However the result is similar.

 

I have made a video about it and uploaded it on youtube:

 

 

Sometimes i can get a half model appearing with animations in Leadwerks and other i can only get a few faces appearing.

Share this post


Link to post

I've got exactly the same issue!

 

When importing it into LW, the only thing which is animated is the light (and shadows) but the shape does not move at all...

 

I'm using latest version of Blender.

 

I'm creating the shape, add the bones, create the link between the bones and the shape, then animate it and save it in dope sheet, then export it with LW export plugin. All seems fine in LW, except what I've written above when I run the animation in Model editor window.

 

I've read several message on the subject in LW (and done the tips in it, like the scaling) but it did not help.

 

Have you found a solution pracedru? Or anybody else?

Share this post


Link to post

I don't have Blender, but can you somehow bake the animation on the character? I'd focus on exporting it with FBX first because that's the most reliable option. Also, is this problem occuring as well when you open the FBX in something else like 3DS Max / Maya / another engine? Then you know whether it's Leadwerks or the exporting.

Share this post


Link to post

Btw, are you using the diffuse shader for animated models for your material? The default diffuse shader is for non-animated objects.

Share this post


Link to post

Thanks to you all for your feedbacks! Good community here! wink.png

 

I'm on Windows 10.

 

I haven't applied any specific texture or changed default names except for the animation action names.

 

I don't know about the diffuse shader because I have used the default settings of the cube but I'll have a look at it.

 

I don't own any other modeler to try but I have tried other blender examples given in forum with discussions around Blender exportation like "man" and "ankh" and I manage to export blender animation to Leadwerks and see the shape moving. So it certainly comes from something I'm doing wrong with Blender.

 

When I export as FBX instead of MDL, I don't even see the shape, despite I have tried several FBX export option combinations. But I will try again as it is more reliable.

 

I'll have a look at all that tomorrow evening (French time!)and big thanks for your suggestions!

Share this post


Link to post

Yeah!!! laugh.png

Applying a material with an animated shaders indeed solved my issue.

 

Big thanks to all!!!

 

I must admit that before this post, for me a shader was only something related to texture to make the object look differently but not to allow to animate it. ph34r.png

Still so much to learn... Great! tongue.png

Share this post


Link to post

hey #1

pracedru

 

 

 

 

 

 

i use blender animated models and i have there more surfaces maybee 5 or more you can test it out , looking too that easy character creation from nick ace here you can find the way to get one of them model with 5 surfaces for your game

 

 

if you use soon the same bones constilations mybe game jonson you can im import new sequences every time via model editor

 

mybee that resolved nearly your case

 

 

Share this post


Link to post

Another way to fix it might be to recalculate the normals , that could be making it not show up also. By the way how did you get the animation to leadwerks? I exported a model to leadwerks from blender as FBX and after i imported it no animation showed up. it said that the animation didn't even exist. Help would be appreciated.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...