Jump to content
YouGroove

Map not saving material change

Recommended Posts

I changed the material on a character , in the editor it is the new material.

When i run the game it uses some old map version :

- it uses the old material

- it uses two characters , but only one is in the scene new version

 

Saving again the map, re launch LE3 has no effect.

post-3271-0-16549600-1445078429_thumb.jpg

Share this post


Link to post

I saved the map as a new map and changed the character material to a developper blue material.

The change in the map worked for the runtime game, than changing again the character material it worked.

 

It is a problem with map saving not saving changes at some point.

Share this post


Link to post

I changed another character textures and again the same bug sad.png

I saved to another map name but the material is still the old not the new one, at run time it is a problem or with the saving of the map or model and material association.

post-3271-0-84600500-1445107625_thumb.jpg

Share this post


Link to post

There is a BIG BUG about cache materials and LE3

 

I deleted the old material and textures from the project BUT :

- LE3 still try to find the old textures and materials no more existing and used by the 3d model

- Running the game it keeps displaying old texture and material

 

 

WHERE LE3 CACHES THE MATERIALS AND TEXTURES ???

Is there some option to clean a project hidden cache ?

post-3271-0-13518800-1445108423_thumb.jpg

Share this post


Link to post

Looks like you moved all of your textures and materials but did you open up the model and reassign the new material to the model's surface? The folder you have clicked in the assets browser is Halloween/ghost/New Folder. Thats where those textures are located now. So you have to go back and rebuild the material to make that the location the textures are being referenced from. Then you will need to open the model and make sure that newly created material is applied to it and saved. You can't just move files around and expect assets that referenced previous file locations to automatically know that.

Share this post


Link to post
Looks like you moved all of your textures and materials but did you open up the model and reassign the new material to the model's surface?

Old material and texture not exist no more i deleted them.

I deleted the 3D model also from assets.

 

I just re imported the 3D model FBX, no way it still display old material blink.png

 

Assets folder : only exist new mat and textures

matbug_Newmat.jpg

 

Running the game : suprise it displays the old

matbug_Nwmat3.jpg

 

 

I expect same at run time than same i see in editor.

 

Anyway, LE3 perhaps just go weird on my laptop.

And it is for the contest, no some pro work , so this is not super important , still super annoying to have a total different result at run time from the editor , i just expect WYSIWYG

 

cctuol.jpg

post-3271-0-04550800-1445109783_thumb.jpg

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...