Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Leadwerks not launching from Steam


gpete

Recommended Posts

Leadwerks is not loading from Steam. If I try to use the steam/rungame icon-link nothing happens.

 

The computer reports Leadwerks is running- but nothing is open- no window, etc.

 

I just bought the Standard edition DLC to add to the indie edition and Steam says it installed it.

 

Anyway - the launch from Steam is dead..... my other Steam items run properly-

 

I am on Win 10 professional..

please help or tell me how to download again from Steam

Link to post

I am having similar issues lately as steam reports leadwerks as still running after I used it and try to run LE again. I have to close Steam by using the task manager (since it will not close steam by normal means since its waiting for LE to close) and restart steam. This lets me restart LE successfully. But then the problem starts all over again.

Link to post

Leadwerks is not loading from Steam. If I try to use the steam/rungame icon-link nothing happens.

 

The computer reports Leadwerks is running- but nothing is open- no window, etc.

 

I just bought the Standard edition DLC to add to the indie edition and Steam says it installed it.

 

Anyway - the launch from Steam is dead..... my other Steam items run properly-

 

I am on Win 10 professional..

please help or tell me how to download again from Steam

 

Without looking too far I wouild say it is because Leadwerks is "already running".... in the process tab!

To check this CTRL+ALT+DEL. choose Task Manager.

If you have windows 10 then look in processes tab under APPS as well as BACKGROUND PROCESSES. Look for Leadwerks item. iof there is one then click on it and then click on End Process.

 

then go back to steam and try again to open leadwerks, it should work

 

Unless perhaps a security enforces something against Leadwerks such as for example Norton internet security for odd reasons and various reasons prevents the use of leadwerks somehow. Then in your firewall, go to your program control, you need to set ALL steam items (2 or maybe 3, I dont remember correctly) and Leadwerks to "ALLOW" or "OPEN" or "SAFE" or "Green light" depending what security sofware you use.

Link to post

I cannot speak for the OP, but in my instance, LE was not running but Steam still thought it was. Like I mentioned above, I had to use task manager to close steam. And its not security preventing it from starting leadwerks. Steam thinks the app is already running so it will prevent launching two instances of the same app. For whatever reasons, leadwerks did not properly shutdown (at least according to steam) even though the leadwerks process was not running. Going through the steps that I listed above seemed to resolve it for me.

Link to post
  • 1 month later...
  • 3 weeks later...
  • 2 weeks later...

I have had such problems with other programs and self compiled console programs in the past.

I thought Win10 was the problem, but it was the Avast Free Antivirus.

I think mostly problematic is there the deep screen modus.

I swiched off the antivirus protection when I compile or will run something I have compiled.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Facebook Twitter Youtube Github Steam
×
×
  • Create New...