Jump to content
AggrorJorn

Leadwerks already running

Recommended Posts

So I booted my computer and tried to launch Leadwerks but I get this error saying its already running.

Looking in my active processes, Leadwerks is clearly not running.

Things I tried to resolve the problem:

  • Restarted steam
  • Restarted computer
  • Verified cache: everything is fine.
  • Other games/software can't launch as Leadwerks is still 'running'
  • Can't delete local content Leadwerks as Leadwerks is still 'running'
  • Force delete leadwerks folder via command prompt not working
  • Switched from beta to default branch but has to wait for download as Leadwerks is still 'running'.
  • Stopped Antivirus.
  • Run windows in safe mode with network enabled
  • Restarted again, even unplugged power.
  • Removed Leadwerks configs.

Anyone else running in to this problem?

Share this post


Link to post

Yeah I had this: http://www.leadwerks.com/werkspace/topic/13846-solved-app-already-running/

 

Maybe I am misunderstanding what you are describing but when I would shutdown Steam via the task manager, it would also remove the "Running" indication in Steam's software panel. So when I restarted Steam, Leadwerks was no longer shown as running in the Steam.

 

Are you saying even if you force Steam to close and then restarted, the Steam software panel still says LE is running?

Share this post


Link to post

Normally I also get the error like macklebee describes above. If I want to restart leadwerks a second time while my computer is on, I am forced to close steam via the process panel first before launching leadwerks again.

 

This time its different as leadwerks doesnt even appear in the process panel. Whats even weirder is that leadwerks is 'running' after a reboot.

Share this post


Link to post

Yeah Leadwerks was not running in my process panel either - Steam just thinks its running. I have to close Steam via the task manager because it will not shutdown normally while it thinks Leadwerks is running. Its like steam missed the fact that the editor shutdown. That steam troubleshooting page I linked to suggests this can sometimes be caused by a silent crash of the app? I have noticed a couple of times this has happened was after the editor would crash on me when performing a build (which just got fixed by Josh a couple of days ago).

 

Showing that LE is running after a computer reboot though is a new one - I haven't seen that. Are you logged into steam with multiple devices by chance when you reboot just the computer?

Share this post


Link to post

For some reasons other games can run although Leadwerks still has the status 'running'.

I have Steam only installed on this machine. I can try to lock my self out via Steam guard on my phone, but honestly I don't think that that would cause the issue.

 

If I run tasklist via command prompt I see 2 leadwerks processes. Trying to kill these process doesn't work. It give me the message that these tasks are currently not being executed.

post-45-0-12832700-1452192323.png

Share this post


Link to post

I have resorted to cleaning up the register by hand as well using tools like process explorer and process hacker. The leadwerks process that is present is both running and not running. I do not have permission to do anything against the process (as administrator). Reinstalling steam and locking my self out from via Steam guard has not affected the issue.

 

Last thing to try is reinstalling windows, which I am not going to do atm. So no Leadwerks for me for a while.

Share this post


Link to post

Maybe the quick restart in Windows is causing it to not "really" restart?

Share this post


Link to post

Also never had this issue right after a clean reboot from Windows.

Only happened when i started and closed leadwerks. Had to restart steam to fix it most of the time.

 

Since i don't think you have leadwerks in autostart, look if you also don't have steam in autostart, check if you haven't this feature enabled where windows tries to resume applications after restart and try to make a real reboot. (not sure if windows really features a quick reboot)

Share this post


Link to post

Since i don't think you have leadwerks in autostart, look if you also don't have steam in autostart, check if you haven't this feature enabled where windows tries to resume applications after restart and try to make a real reboot. (not sure if windows really features a quick reboot)

Leadwerks nor steam is autostarted by booting my computer.

 

Looks like we're not the only app to experience this:

http://steamcommunity.com/app/348200/discussions/0/494631873667427180/

Hopefully this is a Steam issue that can get resolved quickly. Something worth mentioning is that I am participating in the Steam beta branch. Switching to the default branch doesn't affect the issue though.

Share this post


Link to post

Unbelievable. I managed to solve the problem last night by copying all my data (800 GB) from my second harddisk (for games, development and programs) to a third harddisk. I then formatted the second hard disk, reinstalled steam and restored all my data. Leadwerks fnnally started normally again.

 

Unfortunately my victory was really short. Just started my computer to do some actual work and I have the same problem again: 'Leadwerks is already running'. The process is once again not in task explorer and I can't delete Leadwerks since its already running.

Share this post


Link to post
I've fix this bug with a windows update the last 10th december. I don't know if there's a link between the problem I had and the update, but I don't have the bug anymore ^^

Share this post


Link to post

Just get a script that does copies and formats your disk at system boot... rolleyes.gifwink.png

 

Have you tried creating a new user on your pc and executing leadwerks from this new user?

Also, when executing tasklist with the parameter "/V", does it say, the state of the processes is "Running"?

 

EDIT:

Bonus: get the parent process of the leadwerks-processes by issuing:

wmic process where (processid=7276) get parentprocessid

(change the pid with your current values and find the result in tasklist)

Edited by Ma-Shell

Share this post


Link to post

Have you tried creating a new user on your pc and executing leadwerks from this new user?

Also, when executing tasklist with the parameter "/V", does it say, the state of the processes is "Running"?

 

EDIT:

Bonus: get the parent process of the leadwerks-processes by issuing:

wmic process where (processid=7276) get parentprocessid

(change the pid with your current values and find the result in tasklist)

Yep, I created a new admin. Reinstalled Steam (as it was installed per user and not available to other users)

 

Command prompt tasklist tells me that there are 2 Leadwerks process active: 1 master and 1 child. Process explorer says both these process can't be shutdown because I have no access to them. Taskkill with PID and /f (forced) says also something different: the processes are currently not running and can't shutdown.

 

So we have:

  • Both process are active: Tasklist and steam
  • Both process are active but you have no access: process explorer
  • Both process are not active and thus can't be shutdown: taskkill.

Share this post


Link to post

Well I have been holding of to do a clean install of windows 10 (instead of the update from windows 7 I have now.). Guess I'' try that next.

Share this post


Link to post

It always seems to be trouble with those migrate to higher versions of Windows.

I always make a total fresh install when first number changes and have never had a problem (probably because of that)

Share this post


Link to post

I couldn't take it any longer so I reinstalled windows 10. (A fast installation by the way). So Leadwerks is running again. So far so good.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...