Jump to content
TerraformerX

Several problems, please help

Recommended Posts

http://www.leadwerks.com/werkspace/page/tutorials/_/scene-panel-r3

  1. When I hold control down and left-click on the lights, it ignores either control key, and instead selects only the one that I just clicked on. If I continue to use this software, this will waste an enormous amount of time if it's not fixed. However, I can select multiple faces by holding the control key.
    (this is a major bug or logical error)
  2. When I click on an object that's already selected in the top-left viewport, it gets deselected in the scene panel.
    (just an annoyance, but it needs fixed)
  3. When I hit the delete key when the object is selected, it won't delete. I have to use the delete button on the toolbar.
    (either a bug or a logical error?)
  4. When I select an object like a cylinder or box, and I type in 90.0 degrees, nothing happens when I hit enter. I have to click out of the text box for its rotation to change.
    (either a bug or a logical error?)
  5. In tutorial 7, when I was creating the leaf material, it applies the last-used normal map to my leaf material when I chose the diffuse+normal+alphamask.shader file.
    (this is a major bug or logical error)
  6. When I try dragging a material file in the assets tab over to the brush I want to use, nothing happens. The cursor just shows the hand icon like it's over a hyperlink, and it doesn't show anything getting dragged.
    (just an annoyance, but it needs fixed)
  7. I just created a cylinder. The wood material was already selected before I created it, so it looks like wood. When I click on "X" to clear the material in the Appearance tab under the Scene tab, it removes wood.mat from the text box, but when I click on something else, or click on empty space in the top-left viewport, it still has the wood material. When I select the cylinder again, the text has returned. It still has the wood material assigned to it.
     
    (this is a major bug or logical error)
     
    I know you would usually have a material on an object, but in this case, I want to create a plain object without any texture. Is that possible to do after you created an object and applied a material to it?

This is all I have found so far. I also don't have as many buttons on my main toolbar as the person who made the tutorial, and I have the Professional Edition "DLC" installed.

 

I'm learning how to do stuff at a nice pace, but if these are problems with the software itself, then I'm merely reporting them so they can be fixed.

 

If these are problems because of my own ignorance, please tell me what I'm doing wrong, however, I'm pretty sure most of them are not operator errors.

 

I have Leadwerks Editor I'm using Linux. I can provide any other information about my system if it's relevant.

 

For the most part, I like this ide. Please fix these bugs.

 

Thanks

Share this post


Link to post

Note that Ubuntu is the only official supported distro. If the listed issues are happening there as well, Josh will take a look at them.

Share this post


Link to post

Note that Ubuntu is the only official supported distro. If the listed issues are happening there as well, Josh will take a look at them.

Doesn't surprise me. Must be because of Canonical's corporate ties. Regardless, Mint is a derivative of ubuntu.

 

Besides, only marketing for one distro doesn't make sense. Linux distros aren't that different. If one absolutely insists on marketing for only one Linux distribution, you should pick a major one like debian, since it is the parent of so many other popular distros. Ubuntu is in turn a derivative of debian. Anyway, this might sound like a long list, but it works. There are exponentially more things that work than don't (correctly). So while it may have been intended for *buntu, because Mint is a derivative of *buntu, it works. I'm sure it wouldn't work any differently in *buntu, since Mint uses *buntu's own repositories. Besides, I'm done with *buntu. I'll only install it again if I absolutely have to. In fact, I'm thinking of even leaving Mint because it's a derivative of *buntu.

Share this post


Link to post

You are correct in your understanding of the *buntu flavours. :) Personally, I am using Debian Jessie x86_64 and find some of the same issues that you are experiencing, but I live with them and work around them. Some of these issues have been addressed in the forums, so as long as you can use the software just try and work around them.

 

It would seem that Leadwerks has a wrapper, it is not a ported over. Whether Wine, eOn, etc, I do not know and have not looked into, but it is Windows software. The wrapper may be helpful to know to trouble shoot some of the problems, or at least understand what is happening.

 

This does not address how to "fix" the problems, but to let you know that one of your GNU/Linux brothers is experiencing it too. ;)

Share this post


Link to post

If you are willing to share, what is the wrapper for Leadwerks? Aside from that Josh, I am really enjoying the Leadwerks Game Engine, despite the small issues. Since it runs well on Debian Jessie, then it will run well on SteamOS, which you are likely already aware of. wink.png

 

In the Steam Store, Leadwerks still is still only offered for M$, is this deliberate, or and error on their part?

Share this post


Link to post

After some reading, I found out that the old Windows 95 look was due to Steam not working with Adwaita gtkrc-2.0 theme, so it looks like I was incorrect about the wrapper. The only way that I could get Steam to acknowledge another workable gtkrc-2.0 theme was to run it in terminal:

 

GTK2_RC_FILES="/usr/share/themes/Industrial/gtk-2.0/gtkrc" steam &

 

Now Leadwerks does not look so.. well.. Windows 95.

Share this post


Link to post

Bugs are not distro specific, I'm running into same problems on Slackware. Engine works but there is still lot's of to do ...

Maybe creator can focus more on fixing Linux bugs and bring Linux version more in line with Windows one, just saying.

Share this post


Link to post

Bugs are not distro specific, I'm running into same problems on Slackware. Engine works but there is still lot's of to do ...

Maybe creator can focus more on fixing Linux bugs and bring Linux version more in line with Windows one, just saying.

As i know, they will move Leadwerks from GTK to somthing else, question is what will it be... I mean, everybody who deployng software today, try to deploy it with QT but i dont know witch road leadwerks are going...

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...