Jump to content
Diego5714

Leadwerks 4 doesn't run on RadeonSI

Recommended Posts

My problem is the following:

I bought Leadwerks some weeks ago, and now I want to use it.

 

As it requires OpenGL4, I believed that it would run on the latest version of RadeonSI supporting OpenGL 4.1, but when I try to launch the application, A window pops up saying that it "Failed to initialize Graphics" and that I should update my graphics driver. This is a thing that I do not want, as AMD Crimson edition is ****.

 

When i launch the application with steam opened via terminal, it says that it is running in "experimental openGL 3 fallback".

 

Im sure that the driver suports openGL 4.1, as I have checked it via GLXINFO

 

My system is:

 

CPU: Intel Pentium G4400

GPU: AMD HD 7770 (Cape Verde XT)

Ram: 16 GB DDR4

OS: Ubuntu 15.10

Driver: RadeonSI over Mesa 11.3 devel.

post-17075-0-36250100-1457649624_thumb.png

post-17075-0-01068400-1457649631_thumb.png

post-17075-0-63936800-1457649638_thumb.png

Share this post


Link to post

Don't have an ATI to test it but might want to check this post on reddit, seems the original 15.10 radeonsi driver doesn't include opengl4 support, you can use a PPA to get a version that does.

 

 

Might want to use glxinfo | grep "OpenGL version" before and after to verify that you have support.

Share this post


Link to post

Hello together, I have the same problem with the open source mesa driver and my AMD R9 380. Of course the graphic card support OpenGL 4.5 (at the moment with Mesa 13.0.2 only OpenGL 4.3) and even Vulkan but I think Leadwerks check the wrong version string on linux. In mesa the OpenGL version string will always be version 3.0 but the OpenGL core profile version string which is the point of matter is version 4.3. So Leadwerks think the graphic card only support OpenGL 3.0 (what is wrong) and try to start the experimental OpenGL 3.0 fallback what doesn't work.

 

The best solution is that Josh change the OpenGL version string check to OpenGL core profile version string on linux or the second solution is to override the environment variable OpenGL version string.

 

 

glxinfo | grep OpenGL output:

 

OpenGL vendor string: X.Org

OpenGL renderer string: Gallium 0.4 on AMD TONGA (DRM 3.3.0 / 4.8.15-1-MANJARO, LLVM 3.9.0)

OpenGL core profile version string: 4.3 (Core Profile) Mesa 13.0.2

OpenGL core profile shading language version string: 4.30

OpenGL core profile context flags: (none)

OpenGL core profile profile mask: core profile

OpenGL core profile extensions:

OpenGL version string: 3.0 Mesa 13.0.2

OpenGL shading language version string: 1.30

OpenGL context flags: (none)

OpenGL extensions:

OpenGL ES profile version string: OpenGL ES 3.1 Mesa 13.0.2

OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10

OpenGL ES profile extensions:

 

 

Leadwerks.log output:

 

Initializing OpenGL4 graphics driver...

OpenGL version 300

GLSL version 130

Device: Gallium 0.4 on AMD TONGA (DRM 3.3.0 / 4.8.15-1-MANJARO, LLVM 3.9.0)

Warning: Running in experimental OpenGL 3.0 fallback for Intel graphics.

Error: OpenGL4 graphics driver is not supported.

Share this post


Link to post

Hmmm, any idea how I specify a core profile on Linux?

 

Is it specified in the glXChooseVisual() call?

 

Even if I change this, I do not know if the open source AMD drivers will work at all.

Share this post


Link to post

Sorry Josh, but I can't say this too. sad.png

 

But I have found a workaround. When I start steam with the following command:

 

MESA_GL_VERSION_OVERRIDE=4.3COMPAT steam

 

steam show the correct OpenGL Version under 'Help' -> 'System Information' and Leadwerks do a great job even with mesa 13.0.2. wink.png

Share this post


Link to post

Hmmm, any idea how I specify a core profile on Linux?

 

Is it specified in the glXChooseVisual() call?

 

Even if I change this, I do not know if the open source AMD drivers will work at all.

I guess you should set GLX_CONTEXT_FORWARD_COMPATIBLE_BIT_ARB in GLX_CONTEXT_FLAGS_ARB and GLX_CONTEXT_CORE_PROFILE_BIT_ARB in GLX_CONTEXT_PROFILE_MASK_ARB while calling glXCreateContextAttribsARB (see: https://www.khronos.org/registry/OpenGL/extensions/ARB/GLX_ARB_create_context.txt).

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...