Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

SOLVED Cant load an animated model from blender into leadwerks


Recommended Posts

I made simple animated model (cube) just to check how it will work in leadwerks.

But it doesnt play animation sequence in leadwerks model view.

 

Which additional steps must be done to prepare blender animated midel for export for leadwerks?

 

I tried baked animation too, still zero results. Is anyone here uses this engine with actual animated models exported from blender?

Link to post
Share on other sites

I wanted to make this a little bit easier because this issue has come up a few times.

 

Normally if your model uses textures Leadwerks will automatically generate a material file that uses the animation shader. However, since your model does not use textures, no material is generated, so no animation is visible.

 

I changed it so the engine will use an internal animation shader automatically when this occurs.

 

You must opt into the beta branch on Steam to get the update. Animation will only be visible in the Model Editor window in the editor, as the rest of the engine has not been updated yet. You also need to update your project to get the new default animation shader I added.

 

I noticed your model has three animations, but only the second one is visible when selected.

 

post-1-0-95308800-1462389357_thumb.jpg

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...