Jump to content
  • 0
Beastinlosers

Character Controller not working

Question

I have the basic scene up (just the ground (rectangular prism) and the cube). Added the character controller on. Its feet are level with the ground and I have not touched any of the player's settings. Cannot move when running the game. No errors or warnings in Debug menu either. What am I doing wrong. I tried lifting the player model above the ground and that didn't work either. 

Sorry I'm new.:mellow:

Share this post


Link to post

7 answers to this question

Recommended Posts

  • 0

Ok I fixed this problem. I realized I was looking through the default camera and not the view of the player. Since the player was invisible, I didn't see him until I decided to attach a weapon and saw my guy move around. 

To fix: Drag the camera under entities (in the scene menu), onto fpsplayer. 

*Facepalm*

Share this post


Link to post
  • 0

You don't need to create a camera at all when you are using the player with the fpsplayer.lua script. That script creates a camera. Just delete the default camera.

Share this post


Link to post
  • 0

TBH, this happened to me as well and I ended up copying and pasting the FPS player from the tutorial map into my new one.  That worked 100% for me.

Mike

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...