Jump to content
cassius

more on vs 2017

Recommended Posts

Sorry to be so persistant but I am getting desperate.

I start a new blank project  in vs 2017 and add nothing of my own.It gives error message " cannot open source file ctype.h".

This of course is followed by many more errors.

This is a NEW project and surely should work out of the box?

I tried googling for answer but answers were dated.

target is set to 10.015063.0 but retarget shows another number.,, other than that I see nothing wrong.

  • Confused 1

Share this post


Link to post

I just did the upgrade.  This is what worked for me - you may not need to do some of this.

  1. Create new project.  Double click on SLN file in Project, Windows to open.
  2. Changed to Release.
  3. Removed App.h and main.cpp from project.
  4. Replaced the code in App.cpp with an example that doesn't use any resources, like the one on this page: https://www.leadwerks.com/learn?page=API-Reference_Object_Window_Create
  5. When I tried to compile it, it gave me some error about missing Windows 10 SDK (since I didn't install it).  I right-clicked on Solution in the Solution Explorer, hit Retarget Solution, chose 8.1 and hit OK.
  6. This compiled for me but I got a blank window because the Working Directory was incorrect.  Right-clicked on the Project Property, went to Debugging and changed my Working Directory to $(SolutionDir)..\..\   (which matches my Output Directory under General).

Ran fine after this.  Good luck!

  • Like 1
  • Confused 1

Share this post


Link to post

I am now getting the error windows sdk 10.15063.0 not found..its asking me to retarget. Any further help appreciated.

  • Confused 1

Share this post


Link to post

I've now got it  to build ok, thanks for your help.

However, I'm now getting the following error.

Lua Sandbox is ticked in options.

The correct path to the Lua scripts is as below but I'm not sure why it's looking in the wrong place.

 "C:\Users\G\Documents\Leadwerks\Projects\newproject\Scripts"

Can you help, thanks.

Run time error below-

Error: No debugger hostname supplied in command line.

Initializing Lua...
Warning: Lua sandboxing disabled.
Executing file "C:/Users/G/Documents/Leadwerks/Projects/Scripts/Error.lua"
Error: Failed to read file "C:/Users/G/Documents/Leadwerks/Projects/Scripts/Error.lua".
Executing file "C:/Users/G/Documents/Leadwerks/Projects/Scripts/Main.lua"
Error: Failed to read file "C:/Users/G/Documents/Leadwerks/Projects/Scripts/Main.lua".
Error: Failed to execute script "Scripts/Main.lua".
Press any key to continue . . .

  • Confused 1
  • Sad 1

Share this post


Link to post

No.  The output directory is where it puts the EXE.  The working directory is where it should find the DLLs and such.  It's convenient to have them the same if you want to run the EXE outside of Visual Studio.

  • Sad 1

Share this post


Link to post
5 hours ago, cassius said:

Can someone tell me

 

Does the working directory path have to match the output directory??

It should.

  • Sad 1

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...