Jump to content
imothep85

FBX IMPORT BUG !

Recommended Posts

So i spent a full day in leadwerks engine, with tons of errors with fbx import, edges turned visible, model clean in 3ds max, i hidded those edges still same problem.

edges appears  in leadwerks !!!!

i exported in fbx , tested version from 2009  to fbx 2017 version, nothing change

SO i used the same fbx on others engine, also inside Game-Guru.... and you know what???

 

My fbx object is CLEAN!!!

no turned edge !

this is my result under leadwerks 

 

screenshot70.jpg

screenshot72.jpg

Share this post


Link to post

we REALLY need THIS problem be solved !!!!

 

and THIS problem come from Leadwerks engine, not from my 3d model !

 

here my model in 3ds max 2017 

3dsmax_model.jpg

Share this post


Link to post

may be best but a copy of the model for josh so he can check as complaining about the tools does not get fix but sample of the problem will help josh a lot more 

Share this post


Link to post

you can upload here

there 2mb limited but look were you do the text or give as a dropbox llnk ftp or anything that people can download from

Share this post


Link to post

and here i reimported again the fbx object inside Game-guru engine i get the correct result, no flipped edges !!!

fbx_to_game-guru.jpg

Share this post


Link to post

Here! is! your! model! in! several! other! modeling! programs!!! From left to right, 3dcoat, uu3d, hexagon.model.thumb.jpg.e16c7256fe535459eedbdc289e3079b0.jpg

The model has poor edge flows as shown by the banding. Now fortunately LE has a way fix poor modeling skills in the LE Model Editor. Open up model in the model editor, and click TOOLS>Calculate Normals... Try using the angular threshold option and lowering the angular tolerance to clean up the normals on the faces causing the banding.

model_fixed.jpg.a5b0eb2998a35424508c01eb625a4345.jpg

  • Like 3

Share this post


Link to post

Calculating normals does indeed help with darken things, but for some reason leadwerks doesn't have holes in circle things. It has only half of lower.

image.png.ba478eeb9bb1c503fb79d744dd26f338.png

Share this post


Link to post
2 hours ago, Nexerade said:

Calculating normals does indeed help with darken things, but for some reason leadwerks doesn't have holes in circle things. It has only half of lower.

Without posting the model, we can only guess what you are alluding to... holes in circle things? no idea what you are trying to describe. Post the model and what it is supposed to look like in your own post. Do not hijack this bug report with something unrelated to the OP's report.

Share this post


Link to post

Hi guys I am on my way to Goddard space center and then flying to Europe this week, so I can’t investigate this right now but I promise I will get to this.

Share this post


Link to post
12 hours ago, Nexerade said:

Calculating normals does indeed help with darken things, but for some reason leadwerks doesn't have holes in circle things. It has only half of lower.

image.png.ba478eeb9bb1c503fb79d744dd26f338.png

When I've seem this it is usually because the model has not been triangulated before import. In Blender stick triangulate in your stack and it will get applied on export - unless you modify default export options. 

Whilst I think you don't HAVE to do this it can help as otherwise the engine has to decide which way to triangulate a quad which I think can lead to problems sometimes if it decides differently to your 3D authoring program. 

Not really an expert but if you're having problems this may help.  If still problems maybe start a new thread on it.

 

Share this post


Link to post

again but up the model so people can have a look and josh can look later as well

Share this post


Link to post

Works perfectly in 4.6 beta. Probably works in 4.5 (default branch) on Steam as well.

Image1.thumb.jpg.39abc3cae9d7e0ff4dfcd9eddf9d87bc.jpg

Share this post


Link to post
Guest
This topic is now closed to further replies.
×
×
  • Create New...