Jump to content

Changing maps in VR results in error message

Recommended Posts

Not 100% sure if this really is a bug or if I'm doing something wrong but there seems to be no way for me to change /load a different map when using the VRPlayer script. 
I understand that the VRPlayer has no mass or collisionshape so triggers (like in this case the ChangeMap trigger) can't collide with the VRPlayer.

That's why I started doing some tests using an (player independent) object to collide with the ChangeMap Trigger and a new map loads without a problem in the normal (FPS Player) setup. 

However when the same player entity has the VRPlayer script attached to it, the (ChangeMap)trigger does get activated but then the game crashes with the following error message:


This problem seems to be project independent: I've tried it with different (also some default) projects and always get the same error.

I also tried it on two different computers and got the same error (First on a Intel i7-7700/Nvidia Geforce GTX1070 and on a second system with a Intel i7-3770K/AMD Radeon R9 fury X, all drivers being up to date) In both cases I was using a Rift for VR. 

So I was wondering: has anyone managed to load a new map while using the VRPlayer script?

Share this post

Link to post

I have never had a problem with this. Normally an OpenGL error should never happen.

I am in Europe right now and I am having my VR equipment shipped to me here and I will try this out when I get it.

Share this post

Link to post
This topic is now closed to further replies.
  • Create New...