Jump to content
Yue

Full screen no working 4.6 :(

Recommended Posts

 

Any suggestions?

GTX 1050 
Windows 10

image.thumb.png.9bde4589ca7b489f23af21e6988e38cf.png

 

Share this post


Link to post

It works just fine. The system property "devmode" is probably set to "1" inside your project's configuration file located typically here:

C:\Users\<UserName>\AppData\Local\<ProjectName>\<ProjectName>.cfg

 

Share this post


Link to post
24 minutes ago, macklebee said:

It works just fine. The system property "devmode" is probably set to "1" inside your project's configuration file located typically here:


C:\Users\<UserName>\AppData\Local\<ProjectName>\<ProjectName>.cfg

 

Initializing Lua...
Warning: Lua sandboxing disabled.
Executing file "C:/Users/Yue/Desktop/Montacargas/Scripts/Error.lua"
Executing file "C:/Users/Yue/Desktop/Montacargas/Scripts/Main.lua"
Executing file "C:/Users/Yue/Desktop/Montacargas/Scripts/Menu.lua"
Initializing OpenGL graphics driver...
OpenGL version 460
GLSL version 460
Device: GeForce GTX 1050/PCIe/SSE2
Error: Window is NULL
 

anisotropicfilter=32
antialias=4
devmode=0
lightquality=2
screenheight=1080
screenwidth=1920
session_number=23
terrainquality=2
texturedetail=0
trilinearfilter=1
verticalsync=1
waterquality=2


Something strange is going on here, and I really don't know what it is. 

Any suggestions?
 

 

Share this post


Link to post

I couldn't tell from your original post's screenshot that you were running the program from the editor. Apparently when ran from the editor, it will set the devmode property to 1 at runtime no matter what the configuration file has for the setting. So either run the program from the executable itself from windows explorer, hardcode it in the main.lua script, or just place this line in the beginning of your main.lua script:

System:SetProperty("devmode","0") 

 

Share this post


Link to post
3 minutes ago, macklebee said:

I couldn't tell from your original post's screenshot that you were running the program from the editor. Apparently when ran from the editor, it will set the devmode property to 1 at runtime no matter what the configuration file has for the setting. So either run the program from the executable itself from windows explorer, hardcode it in the main.lua script, or just place this line in the beginning of your main.lua script:


System:SetProperty("devmode","0") 

 

image.thumb.png.97ade2d3d8b937c5c18c8a5075c33d75.png

Share this post


Link to post

Works fine for me.  'Window is null' error would imply that there was an issue creating the Window. Try running the project's executable from windows explorer and see if it fails. Offhand it looks like you are having graphic card issues but hard to say since you never give enough information for anyone to do anything other than guess.. Perhaps you should try rebooting your PC?

worse case, try to hardcode the window creation:

window=Window:Create("example",0,0,1024,768,Window.Fullscreen)

 

Share this post


Link to post
11 minutes ago, macklebee said:

Works fine for me.  'Window is null' error would imply that there was an issue creating the Window. Try running the project's executable from windows explorer and see if it fails. Offhand it looks like you are having graphic card issues but hard to say since you never give enough information for anyone to do anything other than guess.. Perhaps you should try rebooting your PC?

worse case, try to hardcode the window creation:


window=Window:Create("example",0,0,1024,768,Window.Fullscreen)

 

image.thumb.png.cf6c062f99e376b7045b0eecb889efcd.png

 

With the simple example, it works, but it looks like this. 
devmode=0


 

Share this post


Link to post

Try running this program instead of the standard main.lua:

rescounter = System:CountGraphicsModes()
System:Print(rescounter)
resolutions = {}
for i = 0, rescounter-1 do
	resolutions[i] = System:GetGraphicsMode(i)
	System:Print("Resolution "..i..": "..resolutions[i].x.." x "..resolutions[i].y)
end
window = Window:Create("Supported Resolutions", 0,0,resolutions[rescounter-1].x,resolutions[rescounter-1].y,Window.Fullscreen)
context = Context:Create(window)

while window:KeyDown(Key.Escape)==false do

	context:SetColor(0,0,0)
	context:Clear()
	context:SetBlendMode(Blend.Alpha)
	for i = 0, rescounter - 1 do
		context:SetColor(1,0,0)
		context:DrawRect(0,0,resolutions[i].x, resolutions[i].y,1)
		context:SetColor(1,1,1)
		context:DrawText(resolutions[i].x.." x "..resolutions[i].y, resolutions[i].x-75, resolutions[i].y-15)
	end
	context:SetBlendMode(Blend.Solid)
	context:Sync(true)
end

It should fill up your entire screen and show all the possible resolutions. If it doesn't then i would say you have something else not related to LE affecting your resolutions/screen sizes... like maybe that Nvidia app I see at the bottom of your screen?

Share this post


Link to post

 

This came out, and if it came out in full screen. o.O?

image.thumb.png.5ed18edc87666fca44f15f93ce67590c.png

 

image.thumb.png.362c5ece35909cb77ea3c7e1873ead57.png



 

Share this post


Link to post

Ok, Fullscreen devmode = 0

 

system:SetProperty("devmode","0") 
rescounter = System:CountGraphicsModes()
System:Print(rescounter)
resolutions = {}
for i = 0, rescounter-1 do
    resolutions[i] = System:GetGraphicsMode(i)
    System:Print("Resolution "..i..": "..resolutions[i].x.." x "..resolutions[i].y)
end
window = Window:Create("Supported Resolutions", 0,0,resolutions[rescounter-1].x,resolutions[rescounter-1].y,Window.Fullscreen)
context = Context:Create(window)

while window:KeyDown(Key.Escape)==false do

    context:SetColor(0,0,0)
    context:Clear()
    context:SetBlendMode(Blend.Alpha)
    for i = 0, rescounter - 1 do
        context:SetColor(1,0,0)
        context:DrawRect(0,0,resolutions[i].x, resolutions[i].y,1)
        context:SetColor(1,1,1)
        context:DrawText(resolutions[i].x.." x "..resolutions[i].y, resolutions[i].x-75, resolutions[i].y-15)
    end
    context:SetBlendMode(Blend.Solid)
    context:Sync(true)
end

 

 

 

 

 

Share this post


Link to post

Oops!

System:SetProperty("devmode","0") 
rescounter = System:CountGraphicsModes()
System:Print(rescounter)
resolutions = {}
for i = 0, rescounter-1 do
	resolutions[i] = System:GetGraphicsMode(i)
	System:Print("Resolution "..i..": "..resolutions[i].x.." x "..resolutions[i].y)
end
window = Window:Create("Supported Resolutions", 0,0,980,553,Window.Fullscreen) --<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
context = Context:Create(window)

while window:KeyDown(Key.Escape)==false do

	context:SetColor(0,0,0)
	context:Clear()
	context:SetBlendMode(Blend.Alpha)
	for i = 0, rescounter - 1 do
		context:SetColor(1,0,0)
		context:DrawRect(0,0,resolutions[i].x, resolutions[i].y,1)
		context:SetColor(1,1,1)
		context:DrawText(resolutions[i].x.." x "..resolutions[i].y, resolutions[i].x-75, resolutions[i].y-15)
	end
	context:SetBlendMode(Blend.Solid)
	context:Sync(true)
end


 

248098234_Sinttulo.thumb.png.54a4d27cc99eebfcf2141b5e75fdc4a6.png

 

Share this post


Link to post

I'll try to explain the following and go to sleep. 


My graphics card is a gtx 1050, it says it has two types of screen resolutions, one called PC.

image.thumb.png.e8d810f23fdd4169bbeea6a3f408396b.png



The other is called Ultra HD, and each format displays different types of screen resolutions.

 

 

image.thumb.png.8d4415a913167dc902edaf6f93e3b1ad.png

What I have noticed is that higher screen resolutions take up all the aspect of the monitor, no problem, but lower resolutions are not displayed correctly in full screen. 



In this case, resolutions lower than this are not displayed correctly in full mode.

 

sss.thumb.png.a8588de342953b61622ab0f7834f2520.png


But if you put higher resolutions on the screen, if you see it correctly.


I don't know what it is, on my laptop, OpenGL 4.5 is used and on this card it is OpenGL 4.6.




I thought it was an nvidia configuration, but I'm not sure about anything. 

Share this post


Link to post

Other software can prevent full screen from working too. I had the Samsung Magician running that did something similar to what's happening here.

Try going back to 4.5 first as 4.6 beta hasn't been updated in months.

Share this post


Link to post
49 minutes ago, reepblue said:

Other software can prevent full screen from working too. I had the Samsung Magician running that did something similar to what's happening here.

Try going back to 4.5 first as 4.6 beta hasn't been updated in months.

 

Since I've known leadwerks, I've always had that problem, apparently not with leadwerks version 4.3, the weird thing is that the computer is newly formatted and only has installed Leadwerks engine and appgame kit. I'm going back to version 4.3 of leadwerks and share what's going on. 

Share this post


Link to post

Well, I don't know if this is any good, but it's not the first time I've reported this on the forums, so I guess persistence sometimes pays off. 

I have returned to Leadwerks version 4.1, and I am running the full screen correctly at a resolution of 800, 600. 

Any suggestions that won't make me think I'm crazy?

Share this post


Link to post

Well, testing Leadwerks 4.2 full screen version, and everything working correctly, screen resolution 800 x 600. Obviously something happens with leadwerks from version 4.3 onwards, although I know that something is not right, the most complicated thing is for someone to pay attention to me about it. I guess, since I'm the only one who's presenting the problem, nobody's interested.  

Share this post


Link to post

call-of-duty-wwii-660x330.jpg

I've found the solution to this, and the culprit is the wretched Windows 10.

Resultado de imagen para windows monstruo

 

 

After going through screen-scaled GPU scaling, I found the solution to this problem.  Windows by default scales to a percentage of 125%, and what you have to do is move this to a percentage of 100%.

image.thumb.png.b08232609c67cf1ca19548a5650027c6.png

 

  • Upvote 1

Share this post


Link to post

Nope. I'm getting the issue, too. Leadwerks will not open full screen on my PC, either. I published a test scene and ran it and it looks like yours (your screenshots at the top of the thread) where it is slammed up against the top-left, leaving a gap at the bottom and right side. This is with me running v4.6, btw.

Share this post


Link to post
5 hours ago, Argent Arts said:

Nope. I'm getting the issue, too. Leadwerks will not open full screen on my PC, either. I published a test scene and ran it and it looks like yours (your screenshots at the top of the thread) where it is slammed up against the top-left, leaving a gap at the bottom and right side. This is with me running v4.6, btw.



 

Hi, one of the things that fixed the problem in Windows was updating windows. And move all the possible settings of the nvida panel, especially the screen scale, although I'm more inclined to think about Windows updates. 

Something that should be understood is that in the Main file, it is configured that when the game is launched from the Leadwerks editor, it always goes to window mode in windows, if on the contrary the problem persists when running the distribution of the program I would try as I mentioned before to update windows or look at the settings of the graphics card. 

Translated with www.DeepL.com/Translator

Share this post


Link to post
7 hours ago, Yue said:

Hi, one of the things that fixed the problem in Windows was updating windows. And move all the possible settings of the nvida panel, especially the screen scale, although I'm more inclined to think about Windows updates. 

Something that should be understood is that in the Main file, it is configured that when the game is launched from the Leadwerks editor, it always goes to window mode in windows, if on the contrary the problem persists when running the distribution of the program I would try as I mentioned before to update windows or look at the settings of the graphics card. 

Translated with www.DeepL.com/Translator

Hi and thanks for responding.

Just for clarity, I am on Windows 10 and ALL updates are current. So, Windows is up to date. This cannot be the problem, then. 

It's not the game being launched from the editor that's causing me an issue. Josh had already stated, elsewhere, that the game, when run from within the editor, is prevented from running full screen. The problem is that I had PUBLISHED my test level as a Windows EXE. When I run that EXE, it does not go to full screen. I'd also downloaded the free Bladequest game and when I run it, it does not run full screen, even though I have full screen set as one of the options. 

I cannot see any Nvidia settings that would affect this, to be frank. And any other game I play runs in full screen without an issue. So, I am only having this problem with Leadwerks games.

Share this post


Link to post
7 hours ago, Argent Arts said:

Hi and thanks for responding.

Just for clarity, I am on Windows 10 and ALL updates are current. So, Windows is up to date. This cannot be the problem, then. 

It's not the game being launched from the editor that's causing me an issue. Josh had already stated, elsewhere, that the game, when run from within the editor, is prevented from running full screen. The problem is that I had PUBLISHED my test level as a Windows EXE. When I run that EXE, it does not go to full screen. I'd also downloaded the free Bladequest game and when I run it, it does not run full screen, even though I have full screen set as one of the options. 

I cannot see any Nvidia settings that would affect this, to be frank. And any other game I play runs in full screen without an issue. So, I am only having this problem with Leadwerks games.

Look at the nvida options under "Adjust the size and position of the desktop".

image.thumb.png.918812699a5c62910f13fe370fb00128.png

 

image.thumb.png.95c62eddcb13e897d0f944f81e9e3bfc.png

Share this post


Link to post

Thank you for trying to help, but this does not change anything for me. My Leadwerks tests all open fixed to the top-left and not full-screen. Leadwerks projects are the only ones that do this on my system. All other games open properly to full screen.

Now, I do have a bit of a different setup in that I have two monitors. Even so, as stated, this has not affected any other games.

Share this post


Link to post
9 minutes ago, Argent Arts said:

Thank you for trying to help, but this does not change anything for me. My Leadwerks tests all open fixed to the top-left and not full-screen. Leadwerks projects are the only ones that do this on my system. All other games open properly to full screen.

Now, I do have a bit of a different setup in that I have two monitors. Even so, as stated, this has not affected any other games.

I'll try to emulate the mistake again. And I'll show you the results....


image.thumb.png.56fb3cd4f30285cd6011ec88a7e18ea0.png
All I did was increase from 100% on windows to 125%.

image.thumb.png.b08232609c67cf1ca19548a5

Share this post


Link to post

In the Mian.lua script I have the following. 

window=Window:Create(title,0,0,0,1024,768,Window.Fullscreen + Window.Center)

Share this post


Link to post
Guest
This topic is now closed to further replies.
×