Jump to content
๐Ÿ’ŽYue๐Ÿ’Ž

Full screen no working 4.6 :(

Recommended Posts

The only way that works correctly is to pass to 100% the scale in windows, however if I put for example in 125 the error is seen and someย  functionsย screen resolutionsย  are not recognized in full screen.

This is not really a problem for me, in the end I will never make a commercial video game to sell it, I think the problem is for those who market their game and the user of it, reports this problem.

Share this post


Link to post

I tell you the following, in the leadwerks root directory there is a folder called "tools", in that folder I found the executable that converts fbx models to mdl. ย What I did was put that executable on the desktop, and dragging a fbx model over that executable and the conversion worked fine. ย But if I try to do that inside the same directory it doesn't work.ย 

fbx2mdl_.exe

Share this post


Link to post

This is interesting, I have in the beta version two converter files for fbx to mdl models, one version is the old version and the other is the new one.




The point is that the new one doesn't work, but when I try to run it from the desktop it tells me that a dll is missing.

Logically I think the new exporter is the heaviest and has the highest number in the version.ย 

image.png.8040c6ca43366b57b39448d3f3442e6e.png
image.png.5c7d242f4ce8f3f82ac540b2c1c57996.png

Share this post


Link to post

You know, you can just drag the FBX file from anywhere (your desktop, out of Windows Explorer, etc.) and drop it anywhere right onto the Leadwerks' editor and Leadwerks will convert the file for you. I just open my Assets tab, drill down to Models, and create my own folder first. Then drag-n-drop a model right in there.

You can also drop FBX files into folders within your Leadwerks project (normally under Models) and Leadwerks will see that there are new FBX files and convert them for you automatically. There's no need to have the converter on your desktop or to have to drop files into the Leadwerks' Tools folder. You should probably leave things alone where Leadwerks is installed and only do things within your project folder, I would think.

1 hour ago, Yue said:

It makes me sad, when someone doesn't tell me what's going on and I have to learn by force.

How were we to even know your problem so we could tell you what to do? You asked us to see if the model converts in Leadwerks beta. We tested it and it did. How could we possibly know what the issue was from that?

Share this post


Link to post

I know, I've been struggling with the problem of the screen for a long time, I just want to say that if it only happens to me it's not a problem, in this case the models have been solved because you need to install the Visual Redistributable c+++ 2012. But no one has any idea what's going on, especially the one developing the program. The beta version has changes in the exporter that needs Redistributable libraries, but I suppose the good thing is that it has been fixed and since windows 10 the exporter is working correctly from the map editor.ย 

Translated with www.DeepL.com/Translator

Share this post


Link to post
7 hours ago, Yue said:

I know, I've been struggling with the problem of the screen for a long time, I just want to say that if it only happens to me it's not a problem, in this case the models have been solved because you need to install the Visual Redistributable c+++ 2012. But no one has any idea what's going on, especially the one developing the program. The beta version has changes in the exporter that needs Redistributable libraries, but I suppose the good thing is that it has been fixed and since windows 10 the exporter is working correctly from the map editor.ย 

Sorry to hear that you had issues when you updated to the beta. It was my understanding that the first time that you installed Leadwerks that it should have installed all the files you needed, including the VC++ redistributable? So I am surprised this is the first that this has come up since you have been using LE for some time now. Did you perhaps delete and re-install LE recently? If so, maybe the redistributable did not install properly during that time? This does apparently happen from time to time according to the posts I see on the Steam forum.

As for the screen issues, hopefully Josh will be able to replicate the problem so he can resolve it. Being over seas away from his main development equipment sometimes makes it hard to troubleshoot.ย 

"It's called being friendly.ย ;)ย " - macklebee

  • Confused 1

Share this post


Link to post

I will be back in California at the end of the week. Going to stay in Washington DC this week for some meetings.

Basically,I got a contract for Leadwerks Software to develop someย VR applications for NASA, using our own engine because it is so fast. I already signed theย contract. It took almost two years of negotiation and sales pitchesย to get this.

So before this was a software company with one way to make money, and now it has two ways of making money, and a foothold in a very specialized niche field that is difficult to get into. In an area of expertise that is primed for explosive growth.

I will explain in more detail in a couple days, but I am going to err on the side of caution and make sure I am not stepping on anyone's toes before I post the news item I wrote.

  • Like 3

Share this post


Link to post
2 minutes ago, Josh said:

Going to stay in Washington DC this week for some meetings.

Doing some LE VR promotions?

trumpVR.jpg.a77b304ec490b3c1785705ad1104fdad.jpg

ย 

Share this post


Link to post
5 minutes ago, macklebee said:

Doing some LE VR promotions?

No more promotions, the real work comes now. Space Force!

I will reveal all in a couple days.

(No, I am not actuallyย doing anything with Space Force, yet.)

  • Like 2
  • Haha 2

Share this post


Link to post

Just wanted to update this thread. I did a complete uninstall of all Nvidia drivers using DDU (Display Driver Uninstaller), which basically boots you into Safe Mode and totally cleans out any remnants of your graphics driver. Then I did a reinstall of the latest Nvidia drivers. This, unfortunately, did not solve the full screen window issue for me. When I run Josh's screen test app or a Leadwerk's game at full screen, the game is not full screen and is partially off screen to the top and left. So, this does not appear to be a driver issue.

  • Like 1

Share this post


Link to post
3 hours ago, Monkey Frog Studio said:

Just wanted to update this thread. I did a complete uninstall of all Nvidia drivers using DDU (Display Driver Uninstaller), which basically boots you into Safe Mode and totally cleans out any remnants of your graphics driver. Then I did a reinstall of the latest Nvidia drivers. This, unfortunately, did not solve the full screen window issue for me. When I run Josh's screen test app or a Leadwerk's game at full screen, the game is not full screen and is partially off screen to the top and left. So, this does not appear to be a driver issue.

You're on the road I've been on for two years.ย 

Share this post


Link to post

I have a 4K monitor here with 200% scaling and everything works fine. Also tried 150% and 125%, and everything worked perfectly.

I can't tell what problem Yue ia having. He is saying he just has one 1920x1080 monitor.

@Monkey Frog Studioย It looks like for you, this is probably only happening when you have two different monitor with two different scaling settings. I have several monitors here with different DPI, so I will try that out. But you're also saying the problem persists if you disconnect the second monitor, so I am very confused.

import("Scripts/Menu.lua")

--Set the application title
title="screen test"

--Create a window
local windowstyle = 0
local winwidth
local winheight
local gfxmode = System:GetGraphicsMode(System:CountGraphicsModes()-1)
--[[if System:GetProperty("devmode")=="1" then
	gfxmode.x = math.min(1280,gfxmode.x)
	gfxmode.y = Math:Round(gfxmode.x * 9 / 16)
	windowstyle = Window.Titlebar
else]]
	gfxmode.x = System:GetProperty("screenwidth",gfxmode.x)
	gfxmode.y = System:GetProperty("screenheight",gfxmode.y)
	windowstyle = Window.Fullscreen
--end
window=Window:Create(title,0,0,gfxmode.x,gfxmode.y,windowstyle)

--Create the graphics context
context=Context:Create(window,0)
if context==nil then return end

--Create a world
world=World:Create()

local gamemenu = BuildMenu(context)

--Load a map
local mapfile = System:GetProperty("map","Maps/start.map")
if mapfile~="" then
	if Map:Load(mapfile)==false then return end
	prevmapname = FileSystem:StripAll(changemapname)
	
	--Send analytics event
	Analytics:SendProgressEvent("Start",prevmapname)
	
	gamemenu.newbutton:SetText("RESUME GAME")
	window:HideMouse()
else
	gamemenu:Show()
end

while window:Closed()==false do
	
	if gamemenu:Update()==false then return end
	
	--Handle map change
	if changemapname~=nil then
		
		--Pause the clock
		Time:Pause()
		
		--Pause garbage collection
		System:GCSuspend()		
		
		--Clear all entities
		world:Clear()
		
		--Send analytics event
		Analytics:SendProgressEvent("Complete",prevmapname)
		
		--Load the next map
		if Map:Load("Maps/"..changemapname..".map")==false then return end
		prevmapname = changemapname
		
		--Send analytics event
		Analytics:SendProgressEvent("Start",prevmapname)
		
		--Resume garbage collection
		System:GCResume()
		
		--Resume the clock
		Time:Resume()
		
		changemapname = nil
	end	
	
	if gamemenu:Hidden() then
		
		--Update the app timing
		Time:Update()
		
		--Update the world
		world:Update()
		
	end

	--Render the world
	world:Render()
		
	--Render statistics
	context:SetBlendMode(Blend.Alpha)
	if DEBUG then
		context:SetColor(1,0,0,1)
		context:DrawText("Debug Mode",2,2)
		context:SetColor(1,1,1,1)
		context:DrawStats(2,22)
		context:SetBlendMode(Blend.Solid)
	else
		--Toggle statistics on and off
		if (window:KeyHit(Key.F11)) then showstats = not showstats end
		if showstats then
			context:SetColor(1,1,1,1)
			context:DrawText("FPS: "..Math:Round(Time:UPS()),2,2)
		end
	end
	
	--Refresh the screen
	if VSyncMode==nil then VSyncMode=true end
	context:Sync(VSyncMode)
	
end

ย 

Share this post


Link to post

I set up one 4K monitor and one 1080p monitor side by side. 4K is display #1.

My code above removes the setting that makes the game run in windowed mode when launched from the editor.

I put Leadwerks Editor in the first monitor and launched, and the game created a full-screen window in display 1 (the 4K one). The application is not DPI-sensitive, so it thinks the resolution is 1920x1080 but is scaled up.

I put Leadwerks Editor in the second monitor and launched, and it launched a full-screen window in the first monitor (exactly the same behavior).

So things are working perfectly with this setup, exactly as it should. If you would like me to try another test application please upload it somewhere.

Share this post


Link to post

I also tried making the 1080p my main monitor, and moved the displays around in weird arrangements. Nothing I did was able to create a problem.

Share this post


Link to post

I'm not sure what to tell you. The screen test file you'd sent me previously and any of my own will not run full screen. This is not the case with any other game (modern like Prey or old like System Shock 2) or game creation system (like Unreal, Unity, or Godot).ย 

Share this post


Link to post

I tried the previously posted test I uploaded here and it works perfectly. I even messed around with the custom screen scaling (that prompt to fix blurry apps) trying to create a problem, and everything still worked perfectly:

https://www.leadwerks.com/community/applications/core/interface/file/attachment.php?id=12437

What GPU do you have? Yue has a GEForce 1050.

You can also callย SetProcessDPIAware() before the window is created (C++ only) but this will make your GUI appear smaller if the window is scaled up.

Share this post


Link to post
Guest
This topic is now closed to further replies.
ร—
ร—
  • Create New...