Jump to content
MarilynManson

Terrain uses more than 1700mb GRAM

Recommended Posts

Terrain uses more than 1700mb GRAM

I have such a problem! I create an empty scene, create a player and a flat terrain 
without any textures, save, turn off the engine for freeing resources, launch it, 
and see that this scene uses more than 1700 MB of graphics memory. 
Can anyone say how this can be, how does a flat terrain without so much texture use so much memory?

System: Dell t5500 Xeon X5650 6/12
24 GB RAM Radeon R9 270x 2gb GRAM Everything is on the SSD of Windows 8.1

 

Share this post


Link to post
Terrane size minimum 256x256. If you set the minimum quality of the terrain, 
then no more than 300Mb is used, but if you set the high, then it reaches 1900Mb. 
I tried to take screenshots, but there are also problems, I get a black image.
I check through MSI Afterburner

Share this post


Link to post

Well yeah, the high resolution will use some very big textures. So only use it if that is what you really want.

Share this post


Link to post

But I don’t even use textures, and if I set lower quality then which textures I wouldn’t use, they look bad, and what textures should be in order to occupy almost 2Gb GRAM? In other engines there are no such problems at the best quality.

Share this post


Link to post

The renderer generates clipmaps for the area surrounding the player. It doesn't really matter if you use textures or not, you are allocating clipmaps for those textures to be rendered to. This is how we are able to support any number of terrain texture layers.

The quality setting can be 0,1,2, or 3. If the highest setting is used (3) then the terrain will use three uncompressed RGB 8192x8192 clipmaps for diffuse and normal, which is works out to be about 1.5 gigabytes. I probably don't recommend using the highest setting.

Share this post


Link to post

To take pictures if you use Windows 10, use the Windows + G key. And do the screenshot.  

Share this post


Link to post
But if you read it carefully, you will see that I have Windows 8.1. 
The problem is not that I don’t know how to take screenshots, 
but that it just saves a black image where I don’t see anything, 
but there is no such problem in other places.

Share this post


Link to post

I always use the printscn key. and then paste to a paint program. If you hold the alt key then it will only save the contents of the current window.

  • Like 1

Share this post


Link to post

If it seems to work, I in full screen mode press the print key and I can capture the screen.

But I'm pretty sure there was a time when that happened, and I don't have the slightest idea that
image.thumb.png.8a6674036614f627789da1eea5d3e337.png

Share this post


Link to post
6 hours ago, Josh said:

I always use the printscn key. and then paste to a paint program. If you hold the alt key then it will only save the contents of the current window.

Great trick with the Alt + Print key

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...