Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • 0

FBX MDL surfaces materials not applied on runtime?


beepboop

Question

The surfaces of the mdl (from converted fbx - attached) doesn't have materials? 

FBX file - mMage.fbx

MDL file - mMage.mdl

Material file (surface 0) - Mage.mat

Material file (surface 1) - MageHead.mat

Material file (surface 2) - MageStaff.mat

1.) In level editor the materials are applied to the model's surfaces - OK 

1569144164_Screenshotfrom2020-11-1810-41-35.thumb.png.0a42402220faec558c11dcffaf7e5bba.png

2.) This is the mdl, there are 3 surfaces 

863755502_Screenshotfrom2020-11-1810-44-56.thumb.png.857d8f972bb6f70114120ae229ac4bb7.png

3.) In runtime the materials are not drawn - the crawler is OK though

1650200224_Screenshotfrom2020-11-1810-41-54.thumb.png.49ad8f4320dc28303a368b6b25ae341a.png

4.) In-game - I went ahead and checked the surfaces of the mdl to see if the materials are still attached, it says there are no materials applied to the surfaces

1129440913_Screenshotfrom2020-11-1810-47-32.thumb.png.81972ac6c92eca08202e96e76fa3c3d7.png

This is the debug info I have:


Initializing OpenGL graphics driver...
OpenGL version 460
GLSL version 460
Device: Mesa Intel(R) HD Graphics 5500 (BDW GT2)
//
// ---> Below are results of my custom loader pre-loading the models I need
//
Loading model "/home/lkj23/Documents/Leadwerks/Projects/Test/Models/characters/base.mdl"
Loading material "/home/lkj23/Documents/Leadwerks/Projects/Test/Models/characters/brown_eye.mat"...
Loading shader "/home/lkj23/Documents/Leadwerks/Projects/Test/Shaders/Model/Animated/diffuse.shader"...
Loading shader "/home/lkj23/Documents/Leadwerks/Projects/Test/Shaders/Model/Shadow/shadow+animation.shader"...
Loading texture "/home/lkj23/Documents/Leadwerks/Projects/Test/Models/characters/brown_eye.tex"...
Loading model "/home/lkj23/Documents/Leadwerks/Projects/Test/Models/characters/Crawler/crawler.mdl"
Loading material "/home/lkj23/Documents/Leadwerks/Projects/Test/Models/characters/Crawler/crawler.mat"...
Loading shader "/home/lkj23/Documents/Leadwerks/Projects/Test/Shaders/Model/Animated/diffuse+normal+specular.shader"...
Loading texture "/home/lkj23/Documents/Leadwerks/Projects/Test/Models/characters/Crawler/crawler.tex"...
Loading texture "/home/lkj23/Documents/Leadwerks/Projects/Test/Models/characters/Crawler/crawlerDot3.tex"...
Loading texture "/home/lkj23/Documents/Leadwerks/Projects/Test/Models/characters/Crawler/crawler_spec.tex"...
Loading material "/home/lkj23/Documents/Leadwerks/Projects/Test/Models/characters/Crawler/crawler_eyeball.mat"...
Loading texture "/home/lkj23/Documents/Leadwerks/Projects/Test/Models/characters/Crawler/d_eyeball.tex"...
Loading texture "/home/lkj23/Documents/Leadwerks/Projects/Test/Models/characters/Crawler/crawler_eyeballdot3.tex"...
Loading model "/home/lkj23/Documents/Leadwerks/Projects/Test/Models/weapons/short-sword/short-sword.mdl"
Loading material "/home/lkj23/Documents/Leadwerks/Projects/Test/Models/weapons/short-sword/Sword_texture.mat"...
Loading shader "/home/lkj23/Documents/Leadwerks/Projects/Test/Shaders/Model/diffuse.shader"...
Loading texture "/home/lkj23/Documents/Leadwerks/Projects/Test/Models/weapons/short-sword/Sword_texture.tex"...
Loading model "/home/lkj23/Documents/Leadwerks/Projects/Test/Models/characters/MageV2/ModelFormats/FBX/mMage.mdl"
Model: 0, Surface: 0, Material: 0
Model: 0, Surface: 1, Material: 0x55d75dee7b70
Model: 1, Surface: 0, Material: 0x55d75e6c06d0
Model: 1, Surface: 1, Material: 0x55d75e75ac40
Model: 3, Surface: 0, Material: 0
Model: 3, Surface: 1, Material: 0
Model: 3, Surface: 2, Material: 0
Loading texture "/home/lkj23/Documents/Leadwerks/Projects/Test/Materials/Common/bfn.tex"...
//
// --> Below are map and models
//
Loading map "/home/lkj23/Documents/Leadwerks/Projects/Test/Maps/foregate.map"...
Loading material "/home/lkj23/Documents/Leadwerks/Projects/Test/Materials/Skyboxes/skybox-pitch-dark.mat"...
Loading texture "/home/lkj23/Documents/Leadwerks/Projects/Test/Materials/Skyboxes/pitch-dark-skybox.tex"...
Loading material "/home/lkj23/Documents/Leadwerks/Projects/Test/Materials/Rock/cobblestone.mat"...
Loading shader "/home/lkj23/Documents/Leadwerks/Projects/Test/Shaders/Model/diffuse+normal+specular.shader"...
Loading texture "/home/lkj23/Documents/Leadwerks/Projects/Test/Materials/Rock/cobblestone.tex"...
Loading texture "/home/lkj23/Documents/Leadwerks/Projects/Test/Materials/Rock/cobblestone_dot3.tex"...
Loading shader "/home/lkj23/Documents/Leadwerks/Projects/Test/Shaders/Editor/wireframe.shader"...
Loading model "/home/lkj23/Documents/Leadwerks/Projects/Test/Models/characters/MedievalNPC2_Scribe/ModelFormats/FBX/mMedievalTownsfolk_NPC2_Scribe.mdl"
Loading model "/home/lkj23/Documents/Leadwerks/Projects/Test/Models/characters/Crawler/crawler.mdl"
Loading model "/home/lkj23/Documents/Leadwerks/Projects/Test/Models/characters/MageV2/ModelFormats/FBX/mMageLOD1.mdl"
Loading model "/home/lkj23/Documents/Leadwerks/Projects/Test/Models/characters/MageV2/ModelFormats/FBX/mMage.mdl"
Loading material "/home/lkj23/Documents/Leadwerks/Projects/Test/Materials/Common/NavMesh.mat"...
Loading shader "/home/lkj23/Documents/Leadwerks/Projects/Test/Shaders/Model/Flat/default.shader"...
Deleting shader "/home/lkj23/Documents/Leadwerks/Projects/Test/Shaders/Editor/wireframe.shader"
Loading shader "/home/lkj23/Documents/Leadwerks/Projects/Test/Shaders/Model/Animated/default.shader"...
Loading shader "/home/lkj23/Documents/Leadwerks/Projects/Test/Shaders/Misc/occlusionquery.shader"...
Loading shader "/home/lkj23/Documents/Leadwerks/Projects/Test/Shaders/Model/Shadow/shadow.shader"...
Loading shader "/home/lkj23/Documents/Leadwerks/Projects/Test/Shaders/Lighting/directionallight.shader"...

 

Link to post

6 answers to this question

Recommended Posts

  • 0

I've tried switching from new fbx2mdl to old (copy pasting it from steam archive - Leadwerks 4.4, 4.5, 4.3), deleting the mdl (so Leadwerks can reconvert the FBX again using the old fbx2mdl) - no change, error still there.

Link to post
  • 0

Added Test.exe to Steam in linux (running Proton). Materials are there. 

- Test.exe - works, with materials on model

- Test (Linux Executable - added to Steam) - doesn't work, no materials on model

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Facebook Twitter Youtube Github Steam
×
×
  • Create New...