Jump to content
Lazlo Bonin

Leadwerks Updater goes on indefinitely

Recommended Posts

Description:

The Leadwerks Updater kept downloading files indefinitely after multiple hours on a fast internet connection, while displaying 100% as progress.

 

Steps to reproduce:

1-Download and run the updater

2-Check "Force update" and "Clean install"

3-Press the update button

 

N.B.: I previously had a demo version installed in "C:\Leadwerks", so perhaps this is related.

Share this post


Link to post

Do you really need "force update" AND "clean install". I used one or the other,not both with le2.

Share this post


Link to post

Never too sure. Besides, if this is the root of the bug, it should be a radio-option and not a checkbox-option.

Share this post


Link to post

Here's a log of the download with just "Force update" checked.

As you can notice, it loops this section forever after being done:

 

Downloading "Projects/DarknessAwaits/Fonts/arial.ttf.meta"...
Downloading "Projects/DarknessAwaits/Fonts/MORPHEUS.TTF.meta"...
Downloading "Projects/DarknessAwaits/Prefabs/Architecture/arch01a.pfb.meta"...
Downloading "Projects/DarknessAwaits/Prefabs/Architecture/column01a.pfb.meta"...
Downloading "Projects/DarknessAwaits/Prefabs/Architecture/column01b.pfb.meta"...
Downloading "Projects/DarknessAwaits/Prefabs/Architecture/column01c.pfb.meta"...
Downloading "Projects/DarknessAwaits/Prefabs/Characters/Goblin/Goblin.pfb.meta"...
Downloading "Projects/DarknessAwaits/Prefabs/Containers/barrel01a.pfb.meta"...
Downloading "Projects/DarknessAwaits/Prefabs/Decorations/switch.pfb.meta"...
Downloading "Projects/DarknessAwaits/Prefabs/Decorations/woodcart.pfb.meta"...
Downloading "Projects/DarknessAwaits/Prefabs/Effects/smallflame.pfb.meta"...
Downloading "Projects/DarknessAwaits/projecticon.tex.meta"...

 

On a side note, it doesn't download the \Engine\Source folder correctly either. I'm missing a lot of files.

Share this post


Link to post

Since no one else has experienced this, I recommend leaving the optional settings unchecked. It is possible these just haven't been used yet and no one noticed a problem.

 

The updater downloads a zip file full of header files into the engine/source folder and then unzips them when finished.

 

I don't doubt this could be a real problem, since I experienced something similar when I was creating the program.

Share this post


Link to post

I worked around it by deleting "headers.zip" and re-running the updater without any option checked, but this is still a bug. ;)

Share this post


Link to post
Guest
This topic is now closed to further replies.
×
×
  • Create New...