Jump to content
drumwrist0123

Exporting model and texture appropriately from Cinema 4D?

Recommended Posts

My buddy who I am working with is making models via cinema, and he bakes the texture and all that but when we import the model its completely white and untextured and just BASIC! How do we get textures to ....export and everyithg with the texture applied to it? Any help would GREATLY be appreciated.

Share this post


Link to post

The model should be in fbx format and the texture in the same sub folder inside your project folder.

In the editor click on assets panel and select your model. It will appear in the panel below. Right click on this panel and give all yor textures a material file and a nrmal map.

Drag and dro the model onto your scene.

 

A fuller descrition can be found in the help files.

Share this post


Link to post

The model should be in fbx format and the texture in the same sub folder inside your project folder.

In the editor click on assets panel and select your model. It will appear in the panel below. Right click on this panel and give all yor textures a material file and a nrmal map.

Drag and dro the model onto your scene.

 

A fuller descrition can be found in the help files.

 

Ok I'm also having a problem with cinema 4d and importing into leadwerks. The model itself is fine. The texture when added, seems to wrap wrong. (like applying my png across all faces. now specific faces.) I'm baking my objects in cinema 4d into png format. What am i missing here?

Share this post


Link to post
(like applying my png across all faces. now specific faces.)

 

Can you post a pictures or your 3D and bitmap files ?

IF you have multiple textures per object you must create multiple materials, than in model editor, dropt the material to the subobject you want. Perhaps Cinema 4D FBX format not so good version as other software also ?

OR perhaps some UV seeting in FBX export from Cinema 4D ?

Share this post


Link to post

Can you post a pictures or your 3D and bitmap files ?

IF you have multiple textures per object you must create multiple materials, than in model editor, dropt the material to the subobject you want. Perhaps Cinema 4D FBX format not so good version as other software also ?

OR perhaps some UV seeting in FBX export from Cinema 4D ?

Certainly. Here is the PNG that was given to me when i baked the object. (WONT LET ME USE A PHOTOBUCKET EXTENSION) http://s1110.photobucket.com/user/STaSHZILLA420/media/LPT.png.html?sort=3&o=1

Here is a picture of the model im trying to use.(WONT LET ME USE A PHOTOBUCKET EXTENSION) http://s1110.photobucket.com/user/STaSHZILLA420/media/Tree.png.html?sort=3&o=0

 

These are the steps I used when trying to import my model and texture to Leadwerks.

 

1. I made my model in Cinema 4d R14 and made my own textures.

2. Then, I selected my group of objects (null) and went to object and then Bake Object

3. I set my texture to be baked as a PNG and set the res to 2048x2048. ( I heard its better to have a res divisible by 8)

4. I then exported my model as an .FBX

5. When importing my model, It show up perfectly. I'm having trouble getting my baked texture image to properly wrap my model. When i generate my Mat and normal map, and then apply them, it just adds the mat on each polygon but it would be the entire image and not just the piece thats supposed to be there.

 

Hopefully this was a sufficient enough amount of information to help solve this problem. Thanks again for responding so quickly.

Share this post


Link to post

Generating a mat file is usualy enough. The textures should aotomaticly go in the right place but .You can invoke the model editor with a right click on the model thumbnail and then try to drag and drop the material ontot he model, but it shouldbe automatic.

 

EDIT:Sorry I meant double click ( not right click )

Share this post


Link to post

So baking the object and getting the texture in a single PNG like the one i sent is the right way to do it? I just feel like theres is one small step that im missing. Is there a tutorial for this specific situation? Thank you for your help.

Share this post


Link to post

I don;tknow what texture baking is but as far as I know I don't do any. Could THAT be the problem?

yes. That could totally be the problem. Ok. so i build my model. Then i merged all the objects and their textures into one model ( not NULL, but actual polygon merge) now the model have about 6 textures. when importing, id have to import 6 different texture files? What about displacement then? this way wouldnt support that.

Share this post


Link to post

I was more or less trying to make the model ( 7 pieces with 7 different textures) into one complete model with one complete texture. so i can basically "re-wrap that one texture back onto the model inside leadwerks. That does not work.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...