Jump to content
rhonaldmoses@gmail.com

libopenal.so.1 missing error when starting the application in Ubuntu 14.04

Recommended Posts

I ran Launcher in the Terminal and got the below error message.

 

 

E: Unable to locate package ia32-libs-multiarch

 

Trying to install ia32-libs-multiarch gave me the below error message.

 

E: Unable to locate package ia32-libs-multiarch

 

Trying to install is32-libs gave the below error.

 

Package ia32-libs is not available, but is referred to by another package.

This may mean that the package is missing, has been obsoleted, or

is only available from another source

However the following packages replace it:

lib32z1 lib32ncurses5 lib32bz2-1.0

 

I installed the above said packages successfully but still when I launch the Launcher, it gives the same error.

 

Please help!!!!

Share this post


Link to post

Have you tried a

sudo apt-get update

before executing the script?

(Ubuntu will then ask for your root-password)

 

This will update the package database of your package-manager (apt-get) and it should be able to find the package after doing this.

 

Actually I thought, the old installer-script did this automatically. Maybe this should be added to the front of the script.

Share this post


Link to post

According to multiple posts in the ubuntu forums, canoncial seems to have removed the package from Ubuntu 13.10 and upwards. But what I think, is quite strange, is that it worked for me in the same version you are using. A workaround for this would be configuring your sources.list to allow installing of older packages. Raring (13.04) seems to be the latest version containing those libs. This (http://ubuntuforums.org/showthread.php?t=2182653) post claims to have found a solution to that, which seems to be essantially the same as I described above (I just quickly scanned through the post). If I find the time, later I will take a look into my own sources.list (currently on windows, so I can't do it now) and post the results here.

Share this post


Link to post

Thans @Ma-Shell, the thread you gave me helped a lot. Basically, the below has to be done under Ubuntu 14.04 since the said packages are removed from Repos.

 

  1. Install Synaptic from terminal window ( Ctrl+Alt+T ) if you have not done so already.
  2. Type or copy this in the terminal minus the quotes " sudo apt-get install synaptic "
  3. Launch synaptic and goto “Settings then Repositories”
  4. Click “other software then add”
  5. Insert this line in the box "deb http://archive.ubuntu.com/ubuntu/ raring main restricted universe multiverse"
  6. click ok and close synaptic
  7. Type or copy minus the quotes in the terminal “sudo apt-get update” Wait until the listing stops and you are at the prompt.
  8. Then type or copy minus the quotes “sudo apt-get install ia32-libs” Wait until install is finished then reboot your computer.

Share this post


Link to post

I updated the install script with the 64 version of the OpenAL lib, which is all you were missing. :)

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...