Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • entries
    880
  • comments
    5,475
  • views
    729,414

Beta update available


Josh

1,060 views

An update is available on the beta branch for Windows, editor and Lua executables only. This fixes a problem in the new light update system:

http://www.leadwerks.com/werkspace/topic/15713-shadow-update-editor-issues/

http://www.leadwerks.com/werkspace/topic/15716-43-child-entities-do-not-cast-shadows/

 

The animation shaders are also modified and they will appear better:

http://www.leadwerks.com/werkspace/topic/15710-all-animated-shaders-have-wrongstatic-normals/

12 Comments


Recommended Comments

http://www.leadwerks.com/werkspace/topic/15716-43-child-entities-do-not-cast-shadows/

 

This issue seems to be "sort of" fixed for the editor, but not in-game (compiled with C++). Did you update the C++ library in the beta branch?

 

I say "sort of" because it now renders shadows, but when you move a child entity, the shadow does not update. Only if you move the parent entity then the shadows for all of the children will update. I did set the shadows to "dynamic" for both the parent and the child.

Link to comment

Okay, if the parent has a different light mode than the child, it can cause a problem with lights that have buffered shadows enabled. That's the only problem I can see. Let me think about that, because that might be considered correct or incorrect behavior.

 

If there is something else, please post a map file for me to try.

 

The C++ library is not yet updated.

Link to comment

Please bring back the performance update from the first 4.3beta if possible. I kinda miss shooting 15 zombies or 25 crawlers at a time with 60fps speed.

Link to comment

Here is a map file that demonstrates the issue at hand. If you replace the point light with a directional light, it renders fine, but with point lights and spotlights, the issue is apparent. http://toxingames.com/leadwerks/shadowissue.zip

This map only produces a blank screen. I added a camera, and it is only a single box with a point light. The script you included does not appear to be used in the scene?

 

There is a pivot in the scene, but I don't know what it does or why it is there?

Link to comment

I can confirm that the shadow issue is now fixed in this update. Good job! Now, I await eagerly for the C++ library to update. ;)

Link to comment

Hmmm... The child shadows (under point lights & spotlights) are still not rendering in C++. They are fine in the editor, but not in C++.

Link to comment
Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Facebook Twitter Youtube Github Steam
×
×
  • Create New...