Jump to content
YouGroove

Material Shade mode not working

Recommended Posts

I used a simple alpha image that works in "Alpha" mode , but it displays a square black texure in Shade mode.

post-3271-0-35995500-1425984383_thumb.jpg

Share this post


Link to post

The texture is likely all black. If you give it a white background instead of using the alpha channel, it will work.

 

This image is for shade (multiplicative) blending. It has a white background and no alpha channel:

post-1-0-28490300-1425999579.png

 

This image is for alpha blending. The color is solid and it uses the alpha channel to indicate the transparency of each pixel:

post-1-0-98933500-1425999604.png

Share this post


Link to post

That's strange , why not using alpha channel like all transparent images ?

It's less confusing when we use transparent to use alpah everywhere insteda of having a specific cases no ?

(and it shouldn't be so hard to change and put alpha in the shader)

Share this post


Link to post

Thanks Shadmar,

 

But once again , it's valuable information hidden in the forum thread instead of docs sleep.png

 

I love how YouGroove actually replied to the original thread (link in shadmar's post), which means he already had the same issue nearly 2 years ago but forgot about it. :)

 

But I agree this stuff needs to be part of (at least) the beginners guide.

Share this post


Link to post
This image is for shade (multiplicative) blending. It has a white background and no alpha channel:

I tested with that image and one of mine and shade don't works well, this is a real bug.

post-3271-0-66321400-1426434774_thumb.jpg

Share this post


Link to post

Confirmed! Shade does not work for me either. Material set to shade. Blends nicely only if the colour of particles is white any other colour will not blend with the background.

 

post-4357-0-65710400-1426437100_thumb.jpg

post-4357-0-79744000-1426437104_thumb.jpg

Share this post


Link to post

I think thats the requirement though - background to be white if using the shade blend and you cant use the start/end color options because it will affect the white background.

 

if using the alpha blend then you can use the start/end color options, as the color doesn't effect alpha. Same can be done with the light blend as the background would be all black and wont be affected by color changes as shown in shadmars post's example.

 

Seems to be a matter of just picking which blend is best for you based on what your texture looks like.

Share this post


Link to post
I think thats the requirement though - background to be white if using the shade blend and you cant use the start/end color options because it will affect the white background.

 

What are the color rules ?

I have no documentation, not tutorial , nothing on that blink.png

 

Just trying using white for the two color slots, it works, the Shade mode is like transparent.

But again it fails : shade mode just don't ract to lights

post-3271-0-65250500-1426457389_thumb.jpg

Share this post


Link to post

There's actually a smoke material included in the default template. Here, I set the alpha curve of the emitter so it only gets up to about halfway, and the smoke blends into this high-contrast scene very well.

 

smoketest.zip

 

post-1-0-58807700-1426464544_thumb.jpg

Share this post


Link to post

I tested your map , and just closing the area with walls , only keeping a point light, we can see Shade mode not working with lightening.

Also i don't ask alpha trick, just simple particles reacting to lightening.

 

 

Here, I set the alpha curve of the emitter so it only gets up to about halfway, and the smoke blends into this high-contrast scene very well.

The Alpha curve don't works with particle, why trying to use it as it has no effect on the particles ?

it's a bug if you were not aware of it sleep.png

http://www.leadwerks.com/werkspace/topic/12137-particle-alpha-bug/

post-3271-0-51209800-1426802953_thumb.jpg

Share this post


Link to post

Yes it works , but not in all Blending cases.

I needed alpha to work even with tracer effect using blende mode = "Light"

For emissive effects it seems it's not possible to control their alpha until you create a custom shader, anyway i won't use it and use other effects instead as a work around.

 

And i think we can forget particle lightening in LE3.

post-3271-0-65217600-1426834897_thumb.jpg

Share this post


Link to post

Yes it works , but not in all Blending cases.

I needed alpha to work even with tracer effect uiing blende mode = "Light"

Light blend does not use alpha for transparency (see shadmar's link above) as the texture would be non-alpha with a black background. But you could set the endcolor to black and this will help fade the particles.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...